Highlighted

Open-sans font issue in iPhone app view after latest update?

Community Beginner ,
Jul 11, 2018

Copy link to clipboard

Copied

Before the latest update for XD on IOS, there were no issues whatsoever with the fonts I worked with. I have all open-sans font formats installed properly on both my Macbook and the iPhone app.

The issue is a bit weird. In desktop view on my laptop, everything looks just fine with no issues whatsoever. However, in the iphone app, some screens look incorrect. Those screens contain words and sentences that share exact same font sizes and formats, yet some have changed in iphone app view. Some changed to regular/light and so on. Even though other words on the same screens share exact same font sizes and formats with those that appear to be corrupted!

The problem only occurs on the iPhone app, the desktop preview on the Macbook is unaffected.

This issue only occurred after I installed the latest XD update on my iphone, even minutes before I installed the update it was working fine without any issues as it always has.

I am currently unable to present my work to anyone using my phone in order to give them a visual first-hand experience of the app.

I'd appreciate any help given.

Views

831

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Open-sans font issue in iPhone app view after latest update?

Community Beginner ,
Jul 11, 2018

Copy link to clipboard

Copied

Before the latest update for XD on IOS, there were no issues whatsoever with the fonts I worked with. I have all open-sans font formats installed properly on both my Macbook and the iPhone app.

The issue is a bit weird. In desktop view on my laptop, everything looks just fine with no issues whatsoever. However, in the iphone app, some screens look incorrect. Those screens contain words and sentences that share exact same font sizes and formats, yet some have changed in iphone app view. Some changed to regular/light and so on. Even though other words on the same screens share exact same font sizes and formats with those that appear to be corrupted!

The problem only occurs on the iPhone app, the desktop preview on the Macbook is unaffected.

This issue only occurred after I installed the latest XD update on my iphone, even minutes before I installed the update it was working fine without any issues as it always has.

I am currently unable to present my work to anyone using my phone in order to give them a visual first-hand experience of the app.

I'd appreciate any help given.

Views

832

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jul 20, 2018

Copy link to clipboard

Copied

Hi Jawadn,

sorry for the delay in response, as per the description, after you update the Adobe XD mobile app, some fonts are appearing incorrectly in the mobile app.

Could you please share the version of the mobile app that you are using? I would also request you to check if that font is listed in Mobile app "Preferences" under "Manage Fonts". If it is not there, kindly sync in using typekit. 

Please feel free to update this discussion in case you need further assistance.

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 20, 2018

Copy link to clipboard

Copied

Hello Atul_Saini,

I downloaded the new update, the one right after the update I had an issue with.

So currently I have the 10.0 Adobe XD version on my iphone.

It actually worked, the problem is solved with this update. I no longer see any issues with the font display on my phone.

However, on the MacBook desktop version it says "2 fonts are missing. Show Missing Fonts"

When I click on it, it shows:

These missing fonts will be substituted with the system font until they become available:

• Open Sans-ExtraBold

• Open Sans-SemiBold

|Copy to clipboard|   or   |OK|

All the open sans fonts are properly synced with Typekit, there's no issue with the fonts any longer on either laptop or iphone, which is super wonderful, yet this pops up each time I open Adobe XD on my laptop and I hope it won't be causing any sudden problems in the future.

I thought i'd just let you know even though it's not an issue for now, but only to keep you up-to-date.

Otherwise, thanks alot for the help since the main issue is solved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 20, 2018

Copy link to clipboard

Copied

Jawadn, I am glad that it's working for you now. Thanks for sharing the details here and please reach out to us here in case you need any assistance about Adobe XD. For other products visit:-https://forums.adobe.com/welcome.

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 31, 2018

Copy link to clipboard

Copied

Atul_Saini,

Please do fix the missing fonts bug.

I just found out that I cannot copy my XD file onto any external memory drive because of the 'missing fonts', when I paste it, it says:

"The operation can’t be completed because one or more required items can’t be found."

(Error code -43)

Appreciate your help Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 31, 2018

Copy link to clipboard

Copied

I have also tried my best to work around the issue by:

- Opening Font Book and 'Resolve Dublicates', 'No Dublicates Found'.

- In Font Book, selecting the Open-sans missing fonts stated in XD and then 'Validate Fonts'.

- I tried removing them and re-installing them as well.

- I tried disabling them and re-enabling them.

None of these methods worked. The fonts appear normally in my project on XD. But the 'missing fonts' claimed by my XD project are deemed missing files on my Macbook and therefore unable to copy them onto any external memory drive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 28, 2020

Copy link to clipboard

Copied

The same thing happened to me. I'm currently using adobe XD version 27.0(3339). 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 14, 2020

Copy link to clipboard

Copied

I'm having the same problem as well 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...