Highlighted

Published Prototype Doesn't Fit-to-Screen (in Browser) in Full Screen Mode

Community Beginner ,
Feb 28, 2018

Copy link to clipboard

Copied

I uploaded a prototype of mine and it doesn't fit the browser screen (Chrome, from two different Windows computers) when maximized in full screen mode. I have several other projects that work fine in full screen mode. This project was my latest one and I uploaded it in December of 2017, whereas the other projects were uploaded in October 2017 and before that. I tried reuploading to no avail. Help? Please see the attached images. Link here: Pioneer Scientific

unnamed.png

ScreenShot_20180227134216.gif

I checked with the team. They investigated your post, and I am sharing their response here.

This is working as expected. Basically artboards are published at 100% and the browser window size dictates what should appear.

This change was made ~2 months ago.

Workaround solutions:

1) Resize window to show all contents.

2) To have artboards scale to fit current browser window manually append the following to the prototype URL “?featureset=fullscreenScaleToFit&fullscreen

So the URL would be as follows: https://xd.adobe.com/view/7da72e5c-13ed-4d20-8201-e2926bbff15c/?featureset=fullscreenScaleToFit&fullscreen

Let us know if this helps.

Thanks,

Preran

TOPICS
Preview, Product issue

Views

11.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Published Prototype Doesn't Fit-to-Screen (in Browser) in Full Screen Mode

Community Beginner ,
Feb 28, 2018

Copy link to clipboard

Copied

I uploaded a prototype of mine and it doesn't fit the browser screen (Chrome, from two different Windows computers) when maximized in full screen mode. I have several other projects that work fine in full screen mode. This project was my latest one and I uploaded it in December of 2017, whereas the other projects were uploaded in October 2017 and before that. I tried reuploading to no avail. Help? Please see the attached images. Link here: Pioneer Scientific

unnamed.png

ScreenShot_20180227134216.gif

I checked with the team. They investigated your post, and I am sharing their response here.

This is working as expected. Basically artboards are published at 100% and the browser window size dictates what should appear.

This change was made ~2 months ago.

Workaround solutions:

1) Resize window to show all contents.

2) To have artboards scale to fit current browser window manually append the following to the prototype URL “?featureset=fullscreenScaleToFit&fullscreen

So the URL would be as follows: https://xd.adobe.com/view/7da72e5c-13ed-4d20-8201-e2926bbff15c/?featureset=fullscreenScaleToFit&fullscreen

Let us know if this helps.

Thanks,

Preran

TOPICS
Preview, Product issue

Views

11.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 28, 2018 0
Adobe Employee ,
Mar 01, 2018

Copy link to clipboard

Copied

I am unable to reproduce your issue in both the browser, and in the full screen mode. I am on Chrome (Windows 10).

inbrowser.png

Full Screen

fulllscreen.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0
Community Beginner ,
Mar 01, 2018

Copy link to clipboard

Copied

Hi Preran,

Perhaps I should clarify. My prototype is specifically set to open in Full Screen mode when opened in a browser through this link: https://xd.adobe.com/view/7da72e5c-13ed-4d20-8201-e2926bbff15c/?fullscreen.

Two separate people using two separate computers have now told me that the prototype isn't sized correctly when they open my link (as shown in my previous post), resulting in the horizontal and vertical scroll bars. Do you have any suggestions as to what might be the cause of this? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0
Adobe Employee ,
Mar 01, 2018

Copy link to clipboard

Copied

I checked with the team. They investigated your post, and I am sharing their response here.

This is working as expected. Basically artboards are published at 100% and the browser window size dictates what should appear.

This change was made ~2 months ago.

Workaround solutions:

1) Resize window to show all contents.

2) To have artboards scale to fit current browser window manually append the following to the prototype URL “?featureset=fullscreenScaleToFit&fullscreen

So the URL would be as follows: https://xd.adobe.com/view/7da72e5c-13ed-4d20-8201-e2926bbff15c/?featureset=fullscreenScaleToFit&full...

Let us know if this helps.

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 1
Community Beginner ,
Mar 01, 2018

Copy link to clipboard

Copied

Hi Preran​,

Attaching "?featureset=fullscreenScaleToFit&fullscreen" to the end of my URL worked like a charm! Thanks for the help!

Capture1.PNG

I know Adobe XD is still in beta. I hope the developers are planning on implementing the aforementioned URL extension into the automatic "Open in Full Screen" option seen below. Apparently, JUST "?Fullscreen" doesn't work in all cases.

Capture2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 1
Adobe Employee ,
Mar 02, 2018

Copy link to clipboard

Copied

Glad to hear that the workaround solution helped. About the support for the URL to open in full screen, am checking with the team. I am not sure if there is anything planned for the near future. Feel free to place a feature request using this link

Adobe XD Feedback : Feature Requests & Bugs

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2018 1
New Here ,
Jun 29, 2018

Copy link to clipboard

Copied

I have the same problem, but it doesn´t work with "featureset=fullscreenScaleToFit&fullscreen"

Captura de pantalla 2018-06-29 a la(s) 09.54.40.png

Adobe XD CC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2018 0
Adobe Employee ,
Jun 29, 2018

Copy link to clipboard

Copied

Hi Marcelal,

Thanks for sharing the screenshot, could you please share the name of the browser that you are using?

if you are using Chrome, please try another browser to view the prototype.

A similar issue has been raised here: - Prototype "Fullscreen-Mode" doesn't work correctly after updating to June 2018 Update – Adobe XD Fee... Published mockup - full screen mode issue – Adobe XD Feedback : Feature Requests & Bugs.​ Please vote for this bug and share your comments.

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2018 0
New Here ,
Jul 02, 2018

Copy link to clipboard

Copied

This is not a similar issue, although the title might suggest so.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2018 0
Adobe Employee ,
Jul 04, 2018

Copy link to clipboard

Copied

Hi JochemN, could you please provide more details about your issue so that we may assist you appropriately?

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 04, 2018 0
New Here ,
Jul 05, 2018

Copy link to clipboard

Copied

Hi, in the previous posts the suggested work-around is adding "?featureset=fullscreenScaleToFit&fullscreen" to the url of a prototype, to get it working properly in Chrome.

I am using Chrome on a mac (Version 67.0.3396.87 (Official Build) (64-bit)), but the full screen mode enlarges the design too much, so it doesn't fit the browser window.

Hopefully you'll be able to reproduce the issue by investigating my test link: Adobe XD CC

Dropbox - Testsite-fullscreen-example-XD.png

Cheers,

Jochem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 05, 2018 0
Adobe Employee ,
Jul 05, 2018

Copy link to clipboard

Copied

Hi JochemN, thanks for bringing this to my notice, I have updated the link in message #7. Please check if that is similar to your request. If yes, please vote for the same and share your comments.

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 05, 2018 0
New Here ,
May 21, 2019

Copy link to clipboard

Copied

Hi Preran,

I published a prototype of composition of 375x666 and is set to open in fullscreen but it is not opening in fullscreen on chrome and safari both. The link is given below:

Adobe XD

Kindly help on this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2019 0
Adobe Employee ,
May 21, 2019

Copy link to clipboard

Copied

Thank you for your link. I tried viewing your prototype in fullscreen mode on Safari and Chrome on my Mac OS.

I clicked the Full Screen mode on the top right hand corner, and then used the green button on the left hand top corner to maximize the screen.

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2019 0
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

Hello

I am having a similar issue with my prototype. Please how can i fix it?

Link:

https://xd.adobe.com/view/8a092143-e3c4-4ba3-6c6b-8e3f484de7b4-fc38/?fullscreen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Adobe Employee ,
Jun 11, 2020

Copy link to clipboard

Copied

 Hi Anastestia,

 

Sorry to hear you are having trouble viewing your design in the browser. It does look fine at my end. Could you please share the screenshot of how it looks at your end?

 

We will try my best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2020 0
New Here ,
Jun 29, 2018

Copy link to clipboard

Copied

Yes, I see, in Safari looks fine but in Chrome not.

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2018 1
Adobe Employee ,
Jun 29, 2018

Copy link to clipboard

Copied

Thanks for confirming the details, please vote for this request and stay tuned for further updates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2018 0
Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

My prototype does not preview properly in any browser. Safari it's warped, and cannot scroll to top of page. Chrome is similar, the page is zoomed in and cannot scroll to top. This was not an issue until I updated XD today!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2018 0
Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

Also XD is telling me to upgrade to publish more than one link (I pay for CC every month) gah!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2018 0
Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

This has happened to me too. A workaround I did was changing the viewport. Before I had my scrolling viewport set at the full height of the page. I switched it to 1800 (height of my browser) and it has worked ok for me. This may not be the case, but its worth a shot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2018 1
Community Beginner ,
Sep 07, 2018

Copy link to clipboard

Copied

This is happening to me too. Full screen should fit to the bounds of the screen so there's no extra scrollbars. It's as if the whole thing is zoomed in. Makes it really unusable - and the only other option is super zoomed out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0