Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Locked

is AIR getting restricted by Xcode 5?

Community Beginner ,
Dec 18, 2013 Dec 18, 2013

Copy link to clipboard

Copied

Hi,

Apple has notified with below statement, so wanted to make sure it doesn't mean to restrict AIR for developing iOS apps

(https://developer.apple.com/news/index.php?id=12172013a#top)

Make Your Apps Work Seamlessly with iOS 7

December 17, 2013

Starting February 1, new apps and app updates submitted to the App Store must be built with the latest version of Xcode 5 and must be optimized for iOS 7. Learn more about preparing your apps by reviewing the iOS Human Interface Guidelines.

Thanks,

Sanniv.

TOPICS
Development

Views

17.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 28, 2014 Jan 28, 2014
Hi All,The issue has been fixed and the build 4.0.0.1619 is available at http://labsdownload.adobe.com/pub/labs/flashruntimes/air/air4-0_sdk_mac.tbz2 for mac and http://labsdownload.adobe.com/pub/labs/flashruntimes/air/air4-0_sdk_win.zip for windows. Please let us know if you will face any issues.Regards,Nimit

Likes

Translate

Translate
New Here ,
Feb 05, 2014 Feb 05, 2014

Copy link to clipboard

Copied

Thank you for the clarification

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2014 Feb 02, 2014

Copy link to clipboard

Copied

I tested the new AIR on iOS 6 3gs, and it worked. Didn’t yet test it on iOS 5 iPad 1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 02, 2014 Feb 02, 2014

Copy link to clipboard

Copied

I used the latest AIR 4.0 SDK beta from labs on my app and it still included MinimumOSVersion 4.3 in the Info.plist (I don't explicitly include this in the app descriptor XML) and the app ran fine when installed on an iPad1 running iOS 5.1.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2014 Feb 12, 2014

Copy link to clipboard

Copied

Are there plans to make AIR 4 work with ios 5 for iPad1 users?  New ipas packaged with AIR 4.0.0.1619 won't run on the iPad 1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2014 Feb 12, 2014

Copy link to clipboard

Copied

This is working on iPad1 as well. Could you please share the sample application with the iPad1 details(OS version) at nimitja@adobedotcom which help us in reproducing the issue if any. 

Regards,

Nimit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 12, 2014 Feb 12, 2014

Copy link to clipboard

Copied

I had no problems at all with AIR 4.0.0.1619 compiling apps that install and run fine on iPad1 running iOS 5.x

Heck, even the MinimumOSVersion still gets set to 4.3 if you don't include it in your app descriptor as well...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

When I try to install an app compiled with AIR 4.0.0.1619 on my iPad 1 I get the following error:

"The app was not installed because it requires a new version of iPad software"

And I cannot upgrade the iOS above 5.1.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

As already mentioned, I'm using the latest AIR 4.0.0.1619 with an iPad1 running iOS 5.1.1 with no problems, and the the ipa even ends up with MinimumOSVersion set to 4.3 still.

What is included in your app descriptor XML under <iPhone><InfoAdditions>, do you include any explicit use of MinimumOSVersion there?

Are you including any ANEs with your app? If so, are any compiled with a

<linkerOptions>

        <option>-ios_version_min XXX</option> in the platform.xml that might be using an XXX OS minimum requirement setting that forces a higher iOS?

After you package up your ipa with AIR 4.0.0.1619, change it to a .zip extension and share the contents of Payload/*.app/Info.plist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

@Jeffrey

Have you successfully submitted an app to iTunes packaged with AIR 4.0.0.1619  that installs and run fine on iPad1 running iOS 5.x?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

Aren't you trying to install your app as an ipa before submitting to the app store or are you only talking about installing an app that is already coming from the App Store?

If it is already on the app store it is dictated by the minimum OS version as determined when you uploaded the binary. You can see minimum os version requirements by going to iTunes Connect and seeing the binary details of the version in question.  This minimum OS requirement is set by the MinimumOSVersion key/value pair in your ipa's Info.plist, so I am asking what that value is before you even submit. This is what determines the requirement on what version of the iOS software is required by the app version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

@Jeffrey,

The Adobe tech specs for AIR 4 dictate that the minimum iOS is 6.1:  http://www.adobe.com/in/products/air/tech-specs.html and this was set in the xml for the app.

So I understand why the app won't install on 5.1.1 if we've set the minimum in the xml to be 6.1. 

My questions are: if AIR 4 will run on an iOS below 6.1, why is the minimum set to 6.1?  And has anyone sucessfully submitted an app to iTunes with the minimum set below 6.1 and had it successfully install on the iPad 1?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

Elsewhere Adobe have said that going forward they are supporting fixes that affect iOS 6.1 or later, but that yes, it does continue to work in 4.3 and later.

As far as I can see, the minimum version is not set in the XML, you have to add that yourself, if you want to override the default of 4.3.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

By the way, the "elsewhere" I mentioned turned out to be in this particular topic! Look in the messages above, for

"51. Pahup, Feb 9, 2014 10:14 PM   in reply to sanniv_ios".

He worded things more optimistically than I did, saying that "however, any bugs which are specific to OS versions lower than 6.1 would get very low priorirty in the bug fix queue."

That means that even bugs affecting iOS 5 might have a chance of being fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

I've used 4.0.0.1619 for a new app, and was able to install and run just fine on an iPod 3rd generation running iOS 5.1.1.  I didn't set any minimum OS version within the app XML file, just let it use the default (the compiler still sets this as 4.3, even though the tech specs mention 6.1).  Unzipped the ipa to double-check and it's set to 4.3 as the minimum, and when uploaded to iTunes it's showing 4.3 as the minimum under binary details as well.  We did a fair amount of playtesting on the iPod running 5.1.1 with this build and didn't notice any problems at all, seemed identical to our earlier builds using 3.9.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

I feel the need to summarize the solution to this, because I had to piece together a lot of the different posts on this thread and one other (http://forums.adobe.com/message/6244866#6244866) to find it.   And then I did something stupid (which cost me a couple of hours), so I'll include that:

1) Go here:  http://labs.adobe.com/downloads/air.html and download either of the bottom two links, whichever is appropriate.  Again, download one of the two links from the "for Flex Developers" section.

2) Review this:  http://helpx.adobe.com/x-productkb/multi/how-overlay-air-sdk-flex-sdk.html, to see how one overlays an SDK (I had no idea and in general terminal in its black-hole-ness terrifies me, if I did it anyone can).  Then overlay that SDK.

3) Then, when you are publishing your app, make sure you go back into the 'package contents' tab and de-click anything that could constitute executable code.  Because it had all been clicked on mine after I overlayed the SDK.  Perhaps I did something wrong when overlaying which caused this, I don't know.  But worth checking.  Because it'll cause the app submission to fail.

Anyway after I did these three steps, apple accepted the app.  I hope this saves someone some stress. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

LATEST

The Flex SDK 4.6.0 is pretty old by now, as it was released back in 2011. After that, it went open source, and you can now download the latest Apache Flex from here:

http://flex.apache.org/installer.html

Using the automatic installer, it will download the latest Apache Flex and will automatically overlay your choice of version of AIR (for Flex developers). You can even choose to overlay AIR 13 beta if you want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines