• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
13

No longer able to submit app to iTunes.

Community Beginner ,
Sep 24, 2014 Sep 24, 2014

Copy link to clipboard

Copied

Today I am trying to submit a new version of an app to iTunes with the application loader but keeps coming up with the following error. The app was submitting fine last Friday. Any help or fixes will be much appreciated.

Package Summary:

1 package(s) were not uploaded because they had problems:

  /var/folders/cc/4b5fjzqn0_n34cll1wzkbk49jhjcnt/T/404743731.itmsp - Error Messages:

  ERROR ITMS-9000: "Invalid Segment Alignment. This app does not have proper segment alignment and should be rebuilt with the latest version of Xcode. Please contact Developer Technical Support if you need further assistance."

TOPICS
Air beta

Views

77.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 25, 2014 Sep 25, 2014

It seems there have been changes in way Apple expects the apps to created. We investigated this deeper, and found that the output of our linker (in our toolchain) is no longer being accepted by Apple.

We are working on this to upgrade our toolchain, including the linker. For the time being,  we would suggest you to try using the ‘linker’ available on the system. We have done tests with a couple of apps and it seems to be fixing the problem. Please give it a try and see if it can unblock you. Ple

...

Votes

Translate

Translate
replies 283 Replies 283
Explorer ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

Pahup, thank you for the quick reply and fix, I was really sweating it last night not being able to get our new build out for our clients.

To windows users, this fix will not work for you because you are working with a mac file, and windows uses .exe  You will have to wait for a windows fix, or get a hold of a mac somehow.

That being said, I had to set up my whole dev environment on my mac partition just to get this to work, it took most of the day, but in the end I was able to submit the app to apple without any issues.  Hopefully a windows fix will be out soon.

The fix does work, it just sucks if you dont have access to a mac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2014 Sep 25, 2014

Copy link to clipboard

Copied

So did you setup Flash Builder 4.7 and Air SDK 15 on your Mac? Then just changed the ld using Pahup's suggestions?

Regards.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

N i didnot set up flash builder in mac , because i developed using flash cs6 right

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

I installed FB 4.6 with air 14 since that is what we are using for dev in windows currently, 4.7 with air 15 should work the same tho.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

I'm usinf Flash prof cs6 with Air sdk 15 beta. and its not working

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

SirRookie, i would assume it should work if you used flash cs6 on mac and modified your air 15 sdk as described in the answer, since the problem lies in the air sdk itself.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

Ok! But I have everything on WIndows. Is ther a way to do it on windows as well ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

As specified in my prior post, no.  There is no solution for windows until Adobe updates the SDK.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

Also make sure you have the latest xcode installed as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

Thank you very much

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2014 Sep 26, 2014

Copy link to clipboard

Copied

Thanks, it works fine with your solution to submit the app even with AIR 15.0.0.274

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2014 Sep 27, 2014

Copy link to clipboard

Copied

I made just like it:

cd <sdk>/lib/aot/bin/ld64

mv ld64 ld64_orig

ln –s /usr/bin/ld ld64

<Build the IPA now using Flash Pro, Flash Builder or on command line>

and it worked very fine. No errors, no warnings in the loader.

Very thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2014 Sep 28, 2014

Copy link to clipboard

Copied

Could you please tell me how to i send my app to itunes

Here is my configuration:

OS: windows 7

IDE: Flash CS6

AIR SDK: 4.0

AIR SDK: 13.0

Please help me , i m stuck here for three days

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2014 Sep 29, 2014

Copy link to clipboard

Copied

Workaround working fine here.

Just uploaded the app to the App Store.

Thanks Pahup!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2014 Oct 01, 2014

Copy link to clipboard

Copied

Change

ln –s /usr/bin/ld ld64

to

ln -s /usr/bin/ld ld64

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Hello Pahup! I can confirm that I am getting the same error "Invalid Segment Alignment". I am submitting my Flash 2014 CC app using AIR 15.0.0.249 and uploading it to Apple via Application Loader 3.0. I can see the workaround that you posted, but I don't understand what I need to do. Is this an addition I need to make to the AS? To the xml?

Can you explain to me (like you're talking to a two year-old, I am a designer and not a programmer) what to do with that fix?

Referring to this:

Steps to make use of system linker -

cd <sdk>/lib/aot/bin/ld64

mv ld64 ld64_orig

ln –s /usr/bin/ld ld64

<Build the IPA now using Flash Pro, Flash Builder or on command line>


Thanks! I know lots of "dumb" designers out there have the same question.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Hi,

We've just posted the entire AIR SDK @ Download Adobe AIR 15 Beta - Adobe Labs - The build number is 15.0.0.302. Please try that out and let us know how it goes.

-Thanks

Pahup

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Fabulous, Pahup!! That did the trick, the app is through and we are now waiting for review. THANKS!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Hello Pahub

Thanks for the update I only get a warning now. Do you know how to solve that?

WARNING ITMS-9000 The executable 'payload/name-for-the-apps.app' is not a position independent. Executable. Please ensure that your build settings are configured to create PIE executables.

I use Flash Pro, Application loader 2.8 and my app.xml is

  <iPhone>

    <InfoAdditions>

      <![CDATA[<key>MinimumOSVersion</key><string>6.1</string><key>UIDeviceFamily</key><array><string>1</string><string>2</string></array>]]>

    </InfoAdditions>

    <requestedDisplayResolution>standard</requestedDisplayResolution>

  </iPhone>

Any idea why I get that warning? Thanks a lot.

Bobby

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

I'm also getting this warning.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

My report with AIR15.0.0.302. I can package for iOS and install on my iOS6.0 device now. Thank you very much, Pahup.

I have not submitted the build to Apple yet, will report back when I do.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

Hi Fiona Passantino, i use Flash Pro CC 2014 for compile my projects and i had the same problem with the "invalid segment", so now i resolved follow the Pahup 's instructions and using SDK 15.0.0.302, then now is not necessary use that's codes lines.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2014 Oct 03, 2014

Copy link to clipboard

Copied

To follow up on my report with AIR15.0.0.302, I tried to submit the app to iTunes but got the following error,

ERROR ITMS-9000: "Invalid Bundle. The bundle xxxx.app does not support the minimum OS Version specified in the Info.plist."

The app installs and runs without any problem on my iOS 6.0 test device. Can someone please advise what is the problem? Thank you very much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

ppl, please read careful this topic. Not just report your isses.

If your ANE use minimum os tag and it's not the same as your app - you will receive this error in case of ANE. Better if your ane will not use minos tag

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines