Button hover state stops working after running this.stop();

Community Beginner ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

I am new to Animate and I have tried looking to see anyone else has had this issue but couldn't find anything...

 

I have a button that works as expected throughout my animation and the hover state works until a frame that I've added this:

this.stop();

Screen Shot 2021-05-24 at 2.08.23 PM.png

I need to use this.stop(); to stop the animation until/unless a user clicks on a second button, at which point it runs a brief animation that slides an info panel in. I noticed that the button hover state stops working after this.stop(); runs...

 

Would this.stop(); prevent button hover states from working? Is there any way to keep the button hover state from breaking/stopping? Thanks!

TOPICS
Code , Timeline

Views

201

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 24, 2021 May 24, 2021
Would this.stop(); prevent button hover states from working? no.  there some else causing the problem.  open your control panel when testing and look for an error message.

Likes

Translate

Translate
Adobe Community Professional ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Would this.stop(); prevent button hover states from working?

no.  there some else causing the problem.  open your control panel when testing and look for an error message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Hi @kglad, thank you for your reply. Do you mean the console or something else? There are no error messages in the console so I'm not sure what else could be causing the button hover state to stop working. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

There was a camera layer in my animation which I don't recall adding, but maybe that happened at some point by accident? I tried deleting the camera layer and tested the animation. Everything is working fine now including the hover state.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

LATEST

yes, i'm sorry.  i meant console.

 

and glad you found the problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines