• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Constant problem with Alt key

Community Beginner ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Hello,

 

I know this has come up over the years on other adobe products, but I have to reiterate something here on the Animate portion of the site.

Windows does this thing where when you hit Alt, as a hotkey it selects the menu at the top of the window. Standard stuff, kind of annoying, but in programs like Animate, it's a constant problem. The alt key is used constantly in any workflow. Any time you want to click and drag a keyframe to copy it, you hit alt. Any time you want to reverse the zoom function, you hit alt. And every time you hit alt, it selects the menu and doesn't deselect unless you hit alt a second time. So doing nearly anything else, like playing the scene, you get the Windows error noise.

I understand that this is Windows' problem to start with. And I also know that you can use AutoHotKey to make a script to bypass this (I can't get the script to work, I don't know if it has to do with a recent Windows update or something, but it's annoying). 

But the fact that this happens at all is pretty weird.  In any other non-Adobe art program, I never have this issue. Because the program is smart enough to know that if I hit Alt to perform an action, like toggling between zoom in/zoom out, it will deselect Alt after the action is finished. So by the time I'm done using Alt for an action, it knows not to have the menus highlighted at the top. 


I understand that the problem is starting with Windows, but Windows doesn't have a way of turning this function off. Adobe users shouldn't have to run a script to bypass the issue here, it should be baked into the software.

Views

1.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Hi mate,

 

I've seen one dev claim that this is inherent to the WinInk implementation.

If you are using Wacom you do not need to rely on Windows Ink. Switch to WinTab from Animate Preferences > Drawing > Tablet Input; switch off Windows Ink for Animate in the Wacom Driver, make sure you restart and see if there is an improvement.

 

Hope this helps!

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

I'll be damned. It did the trick. You're an absolute life saver, this is the last place I would have looked. Thanks very much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Well done, mate! 🙂

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

Yeah, the solution here works... sort of. But when I turn off Windows Ink, Animate ignores the mapping settings of my Wacom tablet. I have a two-monitor setup, and as much as the error dings and the unintentional opening of menus drives me crazy, I can't stand drawing in that mushy state where I have to draw an elongated oval on my tablet to draw a circle on my screen.

Seriously, I don't understand what the problem is, because it doesn't happen in Photoshop. I can use the Alt key to drag out an ellipse or rectangle from the center and it doesn't activate the menu. What makes this problem specific to Animate?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

Adobe Animate Devs,

Will this ever be fixed?

 

I work with 2 monitors as well, therefore I can't use WinTab.

As burbee said, "it is what it is" is not something acceptable here, other Adobe softwares just don't behave like this.

 

Please, it has been a long time now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

I am in the same situation. Please a fix! For wintab or windows Ink but with 2 screens it becomes hell !!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

Seriously. Will this ever be fixed? This forces me to choose between three crappy user experiences. (1) Listen to error dings all day long (2) Have the software ignore my mapping settings and make drawing unpleasant (3) Go back to a one-monitor setup. This has been on-going since at least 2020. And before that there were two years for me where I couldn't update to the current software because using the modifier keys made everything spasmodic and unusable. Is Animate Adobe's forgotten child?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2022 Mar 04, 2022

Copy link to clipboard

Copied

The last response I got from support was "we are working on it. In the meantime use ESC to cancel menu call."

That was like a year ago, and after that I had no more communication from them.

 

@Mohanaraj could you help us here? Any idea if we can hope for a fix anytime soon?

 

 

Cheers

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Holy cow. Just found this the other day and so far it works. It's a script that disables ALT menu acceleration. Finally! <*Sob*> Here's a video showing how it works.

https://www.youtube.com/watch?v=vRld4bVFrpU

And here is where you can find the file on GitHub:

https://github.com/TaranVH/2nd-keyboard/blob/master/Taran's_Windows_Mods/Alt_menu_acceleration_DISAB...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

LATEST

Incredible ! That works !!!
I no longer hear that infernal ding ding from Windows.
Thanks you so much !!

All that remains is to insert this default solution 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines