• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

How do i turn of anti-aliasing in adobe animate

Community Beginner ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

im tryna export a spritesheet in animate cc 2022 but i wanna make it not have anti aliasing. how do i turn it off when exporting

Views

5.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

in the as3 publish settings for png and gif you can disable smoothing.  

 

i'm not sure what format your using for your sprite sheet, but probably png and i assume you're using an as3 project.

 

try it.  i haven't tested.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

yep, im using as3 and png. can you show me an image of where the as3 publish settings are though? i dont see them in the export spritesheet menu thing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

also my bad i meant generate spritesheet

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

click file > publish settings > png > untick "smooth"

 

kglad_0-1670075984865.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

mrmanpersonguydude_0-1670076316759.png

i am using this menu instead.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

i understand.  that's how to generate a sprite sheet.

 

what i'm suggesting is to test that publish setting to see if it has an effect on your sprite sheet.  i know it may not, but it may.  and it's pretty easy to try...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

so, do i just click public and then export the spritesheet?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

public?

 

what/where is public?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

i meant publish oops

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

click file (top left of animate)>publish settings 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

i know where to find publish settings

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

again,

 

click file > publish settings > png > untick "smooth"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

then what

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

then export your sprite sheet as a png and see if there's a difference.  (though @rayek.elfin is doubtful.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

That Smooth setting hasn't worked properly for a long time now. It has no effect on the export.

Just tested it, and it doesn't work.

Also refer to

https://community.adobe.com/t5/animate-discussions/animate-cc-pixel-art/td-p/10755317

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

It hasn't worked for a long time.

There is a workaround if you render to video and use AS3 (which seems to be the case here):

quote

If you're rendering to video you can do that with code. Go to the timeline and put this into frame 1 Actions:

stage.quality = "low"

When you test the SWF or export to video it will be aliased.

 

Source:

https://www.reddit.com/r/adobeanimate/comments/t3vu3h/anti_aliasing_on_lines/

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

render a sprite sheet to video?  how to you do that?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

Just tested it, and it works!

Place that stage.quality = "low" on a new action script layer in the first keyframe.

Then: Export --> Export Video/Media

 

Use the following settings (resolution is your choice, of course):

rayekelfin_0-1670098968850.png

This will generate separate frames of your animation as PNG files with aliased edges.

It will NOT work with the Generate Sprite Sheet function in Animate CC, which means you will have to create your sprite sheet in a different tool.

 

I prefer https://www.codeandweb.com/texturepacker

Btw, older versions accepted SWF files with an addon and would convert to aliased sprites, but even the TexturePacker developers have stopped SWF support.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

Go to the library panel, select the bitmaps, right-click, properties, set compression to lossless/gif and uncheck smoothing. This method will work with the spritesheet generator.

.Mario_CR_0-1670105770244.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

@Mario_CR That method only seems to work for bitmaps, though. Not for vector assets.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

That's correct, the OP is using bitmaps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

You know, I wondered about that. The OP's screenshot shows two photos of a plate of food. That is not typically an export target that requires aliased output. Pixel art animations do, however.

 

Which is why I assumed the OP was using those merely as demo images rather than showing their actual work file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

i didn't pay attention to that screenshot before.  i figured the op knew what they were doing, but after checking it more carefully and seeing 4 frames in that sprite sheet, i'm not so sure about that now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 05, 2022 Dec 05, 2022

Copy link to clipboard

Copied

yeah they were demo images, what i was doing was vector art though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines