HTML file is not working outside Adobe Animate tests

New Here ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

Hey! I'm new here, couple days ago i started a project, made art and animations that i assembled today in Adobe Animate. After many hours of work, it was all finished; if you clicked on a character, the timeline with sound played, after cuple seconds the animation ended. On tests it was all working great, but when i published it as a HTML, after opening it just stopped on the first, default frame, and after clicking on the character nothing happened. I got this warning from the concole: "Frame numbers in EaselJS start at 0 instead of 1. For example, this affects gotoAndStop and gotoAndPlay calls". I would be very very very thankful to whoever can solve this, because my Adobe Animate is ending in cuple days, and i am afraid that i won't be able to finish this project. 

Views

255

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

Hi - Please host your output files (texture/sprite sheets, html, js, images folder etc) in a web server and access it using the URL in a browser in order to access it.

 

Thanks!

Mohan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

LATEST

I don't have a server - my website is on Squarespace. The only way I can show my client an Animate demo is to have my coder upload it to her server - which is ridiculous. Help? TIA.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Hi,

To confirm - did you create an animation with interactivity and test it through Animate via Control > Test Movie > In Browser and this worked fine? However, when you open the published HTML directly outside of Animate, the animation and interactivity did not work?

If the above is the case, then the reason why the HTML it is not playing correctly is due to a brower security issue that blocks JS when they are externnal to the HTML and playing locally. When you do a test in Animate, it simulates a web server and o the JS scipts are not blocked. If you put all your files on a web server, they would work like the test from Animate rather than the test from directly opening the files on your local hard drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines