• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Importing overlaying Photoshop layers produces unwanted artifacts

Explorer ,
Nov 26, 2018 Nov 26, 2018

Copy link to clipboard

Copied

Many times when I import overlapping layers from a Photoshop files, many of the images will have artifacts from other layers. Even if I had check the Create movie clip for each imported layer, I still get artifacts. I have to import the layers with the artifacts individually which is a real pain. I've encountered this problems for years!!!

Why does Animate do this?

Why isn't there an option to import each layer EXACTLY as it appears in PS?

Is there a solution besides exporting the PS layers to separate files and then importing the files into Animate?

Thanks in advance.

Views

964

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 27, 2018 Nov 27, 2018

Hi.

This is really an issue.

An extra advise I can give to you besides reporting this issue is that if your PSD contains shape layers set these layers in the PSD importer to be brought as editable paths. They will look nice and clean. Just don't forget to delete the mask that Animate CC will create for every imported shape.

Also set the text layers to be imported as editable texts fields.

And finally a workaround is to use the script from this thread:

Searching a way for Animate to automatically replace each images with other ones

...

Votes

Translate

Translate
Community Expert ,
Nov 26, 2018 Nov 26, 2018

Copy link to clipboard

Copied

If you believe this is a bug - I'd suggest reporting it here:  Feature Request/Bug Report Form

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

Hi.

This is really an issue.

An extra advise I can give to you besides reporting this issue is that if your PSD contains shape layers set these layers in the PSD importer to be brought as editable paths. They will look nice and clean. Just don't forget to delete the mask that Animate CC will create for every imported shape.

Also set the text layers to be imported as editable texts fields.

And finally a workaround is to use the script from this thread:

Searching a way for Animate to automatically replace each images with other ones

The basics steps are:

- Open your PSD and export the bitmap layers as PNG to a folder of your choice;

- Go to Animate CC;

- Import the PSD (try to remember setting shapes and texts to be brought as suggested above);

- Select the root folder of the PSD in the Library;

- Run the script from the link above.

Regards,

JC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 11, 2023 Apr 11, 2023

Copy link to clipboard

Copied

How to import a PSD:

Captura de pantalla 2023-04-11 a las 14.08.57.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2023 Apr 11, 2023

Copy link to clipboard

Copied

LATEST

locked

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines