• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Masking problems

Explorer ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

So I made an eye animation, and the pupils kind of go out of the eye so I decided to use clipping mask, the pupils are animated as they are supposed to be without clipping mask but when I turn it on the left pupil dissappears for the part where its supposed to be animated, even though it shows up fine when clipping mask is off, please help.

sxshley_0-1617559213750.png

 

TOPICS
Error , How to

Views

638

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Guru , Apr 04, 2021 Apr 04, 2021

If your mask consists of two separate ovals, make sure they are broken apart and appear as shapes, not separate Drawing Objects (or even one Drawing object).
Go inside the mask symbol, Break Apart, deselect, exit symbol. All should be fine now.

 

Votes

Translate

Translate
Guru ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

 

You can also download and study some production quality sample rigs from here: https://flash-powertools.com/tag/free-download/

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

I did these, but the left iris frames are disappearing for no reason when masking is on for the whites, while when masking is off the irises show up just fine. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

If your mask consists of two separate ovals, make sure they are broken apart and appear as shapes, not separate Drawing Objects (or even one Drawing object).
Go inside the mask symbol, Break Apart, deselect, exit symbol. All should be fine now.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2023 Sep 05, 2023

Copy link to clipboard

Copied

I've tried this and they still don't show up when the mask layer is set to visible (the mask layer also doesn't appear even when set to visible but I'm okay with that). The second I make the mask layer hidden I can see all the masked layers below it but they don't operate as "masked" anymore, despite the layer symbol indicating as such. I have another series of masked layers below it operating perfectly so I'm not sure what the issue could be.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2023 Sep 05, 2023

Copy link to clipboard

Copied

hiding a mask is expected to negate the masking effect.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Sep 05, 2023 Sep 05, 2023

Copy link to clipboard

Copied

@Abby320033125hng 

If you upload your FLA somewhere and post a link I'll have look.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2023 Sep 06, 2023

Copy link to clipboard

Copied

I was able to work around it by copying and pasting the other mask that was working. So it must've been an issue with the object I as using as a mask. Thank you though!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 06, 2023 Sep 06, 2023

Copy link to clipboard

Copied

LATEST

@Abby320033125hng 

 

good to hear.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines