Highlighted

Animation resets to first frame, even without loop.

New Here ,
Feb 26, 2019

Copy link to clipboard

Copied

I've been using Adobe Animate lately to do some web animations in HTML5 for various companies. However I recently came across a problem where the animation resets to the first frame and stays on it when loop timeline is unchecked. These aren't supposed to be looping animations, so it's causing quite a problem as I can't figure out what exactly is causing this.

How do I make it stay on the last frame after the animation ends?

Hi Sergiolink

Make an extra layer, call it "scripts" or "actions", create here in the last frame a keyframe and go to Window -> Actions and type into the Actions panel:

this.stop();

Klaus

Views

275

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animation resets to first frame, even without loop.

New Here ,
Feb 26, 2019

Copy link to clipboard

Copied

I've been using Adobe Animate lately to do some web animations in HTML5 for various companies. However I recently came across a problem where the animation resets to the first frame and stays on it when loop timeline is unchecked. These aren't supposed to be looping animations, so it's causing quite a problem as I can't figure out what exactly is causing this.

How do I make it stay on the last frame after the animation ends?

Hi Sergiolink

Make an extra layer, call it "scripts" or "actions", create here in the last frame a keyframe and go to Window -> Actions and type into the Actions panel:

this.stop();

Klaus

Views

276

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 26, 2019 0
Advocate ,
Feb 26, 2019

Copy link to clipboard

Copied

Hi Sergiolink

Make an extra layer, call it "scripts" or "actions", create here in the last frame a keyframe and go to Window -> Actions and type into the Actions panel:

this.stop();

Klaus

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2019 0
New Here ,
Feb 27, 2019

Copy link to clipboard

Copied

thanks, that worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2019 0
kdmemory LATEST
Advocate ,
Feb 27, 2019

Copy link to clipboard

Copied

Pleasure

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2019 0