Export MP4 with actionscript

New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

I've created an animation that uses simple ActionScript - such as a "stop();  and setTimeout()" functions on movie clip symbols to stop the animation but keep the content on the screen without needing to insert hundreds of frames. 

However, when I export it looks like the file just cuts out on the first frame with script in it. Of course, it makes sense - mp4's don't use ActionScript. I was hoping there was a way to get animate to recognise these functions and export the mp4 with them?

(I've also tried importing the swf into after effects, but again it just ignores the script and the clip ends up being 2 seconds long rather than the 10 or so it would be with the script)

 

TOPICS
ActionScript, Import and export, Publish package

Views

76

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Same issue. I can't output an MP4 that plays through the movieclips like the SWF does.

There's no interaction on actionscript required for the MP4, it's just code controlling the timeline to be able to efficiently and easily make edits, but at present it seems you have to manually extend everything in a way that makes editing laborious and limited.

That seems ridiculous, can Animate really not output a video using it's own code?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

LATEST

As a general advice: don't use movie clips (with or without scripting) in animation projects, that will end up as video files. Use movie clips only in interactive projects.


Now, for the particular issue: try to change the instance type of the movie clip to 'graphic', set the desired looping behaviour - 'play once', 'loop' or what you want and extend the clip in the desired frame range in the timeline.


- Vlad: UX and graphic design, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines