Highlighted

Camera Raw 12.0 Very Slow

Community Beginner ,
Nov 05, 2019

Copy link to clipboard

Copied

Hi!

 

I updated to Camera Raw 12.0.1 today and performance in the app is very, very laggy. As another poster described, it takes from 2-5 seconds for an image to appear in the working window. 

 

In the previous version, an image would appear immediately but would take a second or two to come out of preview completely, whereas in v12 the image does appear to switch out of soft, low-res preview image state fairly quickly once it finally does load. 

 

In this version, previews load fairly quickly at first, decreasing after a few previews to the aforementioned laggy response time. If any adjustments are made on the panels, the laggy response happens instantaneously. 

 

I've followed all the steps here:

 

https://helpx.adobe.com/in/photoshop/kb/acr-gpu-faq.html#Troubleshooting

 

And gotten no results whatsoever. Turning on/off/auto the GPU in ACR doesn't do anything to affect the performance. 

 

I'd appreciate any feedback available; I've got three shoots to get through and it's going to take me literally 3-4 times as long to process images as usual. If the solution is to downgrade, please let me know. 

 

I've seen another post regarding this topic on this forum, but it appears to be dead so I decided to post again. 

 

Additional info: 

 

mac OS Catalina 10.15.1

iMac 27" 4.2 gHz i7, 64 GB RAM

 

Thanks!!

 

Thank you to folks who provided additional information. Right now my advice is still to run the 11.4.1 standalone installer to go back to the previous version from 12.0 if you experince this slowdown. FYI you should be able to use Camera Raw 11.4.1 with both Bridge and Bridge 2019 and 2020; I don't believe it's necessary to rollback both Photoshop/Bridge and the plugin. (Camera Raw 11.4.1 will still read the Bridge 2019 preferences for the UI color and color labels, however.)

 

I’ve got some reproducible cases where 12.0 underperforms 11.4.1 in apples-to-apples comparisons (ruling out other sources of slowdowns), so we can dig into the root cause and work on a fix for the next version.

 

Thanks,

David

Topics

Bug, Mac, Performance, Problem or error

Views

4.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Camera Raw 12.0 Very Slow

Community Beginner ,
Nov 05, 2019

Copy link to clipboard

Copied

Hi!

 

I updated to Camera Raw 12.0.1 today and performance in the app is very, very laggy. As another poster described, it takes from 2-5 seconds for an image to appear in the working window. 

 

In the previous version, an image would appear immediately but would take a second or two to come out of preview completely, whereas in v12 the image does appear to switch out of soft, low-res preview image state fairly quickly once it finally does load. 

 

In this version, previews load fairly quickly at first, decreasing after a few previews to the aforementioned laggy response time. If any adjustments are made on the panels, the laggy response happens instantaneously. 

 

I've followed all the steps here:

 

https://helpx.adobe.com/in/photoshop/kb/acr-gpu-faq.html#Troubleshooting

 

And gotten no results whatsoever. Turning on/off/auto the GPU in ACR doesn't do anything to affect the performance. 

 

I'd appreciate any feedback available; I've got three shoots to get through and it's going to take me literally 3-4 times as long to process images as usual. If the solution is to downgrade, please let me know. 

 

I've seen another post regarding this topic on this forum, but it appears to be dead so I decided to post again. 

 

Additional info: 

 

mac OS Catalina 10.15.1

iMac 27" 4.2 gHz i7, 64 GB RAM

 

Thanks!!

 

Thank you to folks who provided additional information. Right now my advice is still to run the 11.4.1 standalone installer to go back to the previous version from 12.0 if you experince this slowdown. FYI you should be able to use Camera Raw 11.4.1 with both Bridge and Bridge 2019 and 2020; I don't believe it's necessary to rollback both Photoshop/Bridge and the plugin. (Camera Raw 11.4.1 will still read the Bridge 2019 preferences for the UI color and color labels, however.)

 

I’ve got some reproducible cases where 12.0 underperforms 11.4.1 in apples-to-apples comparisons (ruling out other sources of slowdowns), so we can dig into the root cause and work on a fix for the next version.

 

Thanks,

David

Topics

Bug, Mac, Performance, Problem or error

Views

4.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 05, 2019

Copy link to clipboard

Copied

I agree, upgraded Camera Raw yesterday and speed is at a snail's pace.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 05, 2019

Copy link to clipboard

Copied

I too had the same problem, and I do not find the solution to this problem.
I hope we will have an answer to this problem soon.

 

VPN Sai Mannat AnyDesk

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 05, 2019

Copy link to clipboard

Copied

Hello,

 

I've also turned the GPU in Camera Raw on and off. It seems a little slower without the GPU, and so I'm having to limp along with Camera Raw behaving in a way it never has. I am processing a lot of 22MP images, and the slow response is really difficult to deal with. If anyone has any ideas to speed it up, I'd be very grateful to hear them.

 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 05, 2019

Copy link to clipboard

Copied

I agree.  I too am having the same issue.  I tried turning off the GPU and it didnt help.  Is there any way to go back to an "older version" of ACR?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 06, 2019

Copy link to clipboard

Copied

I have gone ahead and downgraded back to Photoshop 2019 by uninstalling via the CC app and when reinstalling selecting the elipsis and "previous versions" button. Then I deleted this file:

 

Your-Hard-Drive-Name-Here/Library/Application Support/Adobe/Plug-ins/CC/File Formats/Camera Raw.plugin

 

and reinstalled the Camera Raw plugin from here:

 

https://helpx.adobe.com/camera-raw/kb/camera-raw-plug-in-installer.html

 

I reinstalled the 11.4 version. 

 

Everything's back to normal. I really like the save/read/write speeds for the rest of v12, so I hope they address this issue soon. I may try to update Photoshop itself and keep the old ACR for now to see if that works, but for now I have work to do. Hope this helps someone. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 08, 2019

Copy link to clipboard

Copied

I also had the exact same problem three days ago when I installed Photoshop CC 2020 and Bridge 2020. Immediately Camera Raw 12 was very slow to load images into the workspace window when opened from Bridge (several seconds delay before appearing). Then there would be laggy delays of 5-10-15+ seconds (usually accompanied by the spinning beachball) when I would make adjustments with the basic panel tools, adjustment brush, radial filter, etc.

 

Since I also have work to do, I followed your recommendations and downgraded back to Photoshop 2019 and Bridge 2019 via the CC app, and then reinstalled the Camera Raw plugin (version 11.4). Now everything is back to working as before on my 2018 Mac Mini (3.2 GHz Intel i7, 16GB RAM, Mac OS Mojave 10.14.6).

 

Thanks for your helpful information. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 08, 2019

Copy link to clipboard

Copied

Glad to help. 

 

I'm optimistic that the Camera Raw team at Adobe will be addressing this issue as soon as they can. The performance of opening and saving files from version 12 is really impressive. As soon as they fix the in-app delay it will once again be a fantastic piece of software. Glad they are able to offer the older version while the bugs get worked out for the production geeks out there. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 09, 2019

Copy link to clipboard

Copied

I also have this issue - but have Installed Photoshop 2020 and reverted to Camera RAW 11.4.1 and it works fine. Soi will await further Camera RAW updates from Adobe as regards the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2019

Copy link to clipboard

Copied

Yes, I just just installed Camera Raw 11.4.1 without uninstalling anything and it's fine. Can download it here:

https://helpx.adobe.com/camera-raw/kb/camera-raw-plug-in-installer.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 11, 2019

Copy link to clipboard

Copied

Thank you to folks who provided additional information. Right now my advice is still to run the 11.4.1 standalone installer to go back to the previous version from 12.0 if you experince this slowdown. FYI you should be able to use Camera Raw 11.4.1 with both Bridge and Bridge 2019 and 2020; I don't believe it's necessary to rollback both Photoshop/Bridge and the plugin. (Camera Raw 11.4.1 will still read the Bridge 2019 preferences for the UI color and color labels, however.)

 

I’ve got some reproducible cases where 12.0 underperforms 11.4.1 in apples-to-apples comparisons (ruling out other sources of slowdowns), so we can dig into the root cause and work on a fix for the next version.

 

Thanks,

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 11, 2019

Copy link to clipboard

Copied

David, 

 

Thanks very much for your clarification and for being so responsive with this issue. It really does speak to your expertise and willingness to help out the users of Adobe's products. 

 

Kindest regards!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 11, 2019

Copy link to clipboard

Copied

David, let me also thank you for your update and quick response to this issue.  I am encouraged to know that Adobe is aware of the problem and will be working on a fix. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 12, 2019

Copy link to clipboard

Copied

Hello David,
i installed Camera Raw v12.1 yesterday and the problem with me is the same as with the v12. It is then no longer possible to work fluently, everything only happens with a great delay and the CPU load is 25-40% only for camera raw on my win10 station. I also went back to the v11.4.1, this works without any problems.

 

Thx a lot & regards

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Dec 12, 2019

Copy link to clipboard

Copied

Thank you for reporting that you are still having problems with 12.1. It's not clear to me from this thread what the root cause of your problem is in your case. Known issues with 12.0 included: OpenGL being deprecated (same applies to 12.1), problems with the Acronis product (detailed in this thread), and very poor performance thubmnailing/peviewing photos in Bridge when browsing raw files or other photo files supported by Camera Raw (fixed in 12.1!). Your issue may be different. I don't know.
 
We have updated the Camera Raw GPU FAQ and troubleshooting guide recently. It includes some information-gatehering troubleshooting steps that may shed some light on the problem.
 
 
-David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 13, 2019

Copy link to clipboard

Copied

Hello David,

the performance problem with Camera Raw 12.1 no longer exists if the Acronis service "AcronisActiveProtectionService" was previously deactivated. The cross-check showed that with the activated service "AcronisActiveProtectionService" Camera Raw very much delayed. My solution to the problem is to disable the "AcronisActiveProtectionService" before Adobe Bridge / Camera Raw starts.


Thx a lot & regards

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 29, 2020

Copy link to clipboard

Copied

Hi David,

 

thanks for the suggestion.  It was Acronis, once I have removed it, there is no longer a lag issue.

 

Mano

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 01, 2020

Copy link to clipboard

Copied

You're the man. I confirm the link with Acronis.
As suggested, I've deactivated AcronisActiveProtectionService from 'services.msc' (Windows 10) and CamaraRoaw 12.2 is now working like a charm. Just that I've not to forgot to reenable it after my Phostoshop session.

Thanks so much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 01, 2020

Copy link to clipboard

Copied

As I mentioned in my Feb. 4 post here there's a better solution:

I contacted Acronis support and they gave me a better solution than turning off Active Protection. Instead, go into the Manage Processes tab of the Active Protection dashboard and add Photoshop to the whitelist. After doing that Camera Raw now runs as normal for me but I'm not giving up the Active Protection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 02, 2020

Copy link to clipboard

Copied

That is perfect. I've added Photoshop.exe did in the Acronis Active Protection whitelist as recommended it and it works like a charm.
I added :

C:\Program Files\Adobe\Adobe Photoshop 2020\photoshop.exe

C:\Program Files\Adobe\Adobe Photoshop 2019\photoshop.exe

 

So many thanks.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 16, 2020

Copy link to clipboard

Copied

Wow! I have been suffering with ACR performance issues for so long! Hitting the "Auto" button to automatically adjust exposure etc. would take 10-15 seconds to repaint. The adjustment brush was simply unusable (brush....wait 10 seconds... brush again!). Remarkably the lags are only in ACR, not Photoshop. I thought it was my graphics card. I would never have made the link to Acronis. I whitelisted Photoshop (and Bridge) in Acronis Active Protection, opened a camera raw image (through photoshop), and the "auto" button is now almost instantaneous. The adjustment brush is massively improved (still a very slight lag at the end of a stroke). All in all, this is a remarkable improvement. Many thanks David.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 30, 2020

Copy link to clipboard

Copied

I have Acronis TrueImage 2020.  I can see the Active Protection, but I don't see anything that is called a "white list." 

What does this mean?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 30, 2020

Copy link to clipboard

Copied

I found the Manage Processes, I added Photoshop and Bridge.  I tested everything.  I works!!!

 

Wonderful.  I am so greateful that I was able to find this solution to my problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 30, 2020

Copy link to clipboard

Copied

Happy to learn it.

As a reference to fix this performance issue, here is a screenshot that explains how to whitelist the Adobe Photoshop processes in Acronis Tye Image 2019 avoiding then performance issues.

31-03-20 08-50-47.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 22, 2020

Copy link to clipboard

Copied

Been struggling with this for months. This fixes the problem . All now working fast with ACR - Great stuff .

Thanks Guys

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...