• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Assistance with an MP4 background slide, buttons and shapes

Explorer ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

Hi - assistance or advice greatfully accepted!

I am currently trying to build a project using an MP4 background (moving image) and have created my opening slide - video plays nicely in the background, text box(es) fade nicely into view.. all good.

 

Ideally id like for the a button to be pressed, the initial text box fades out and is replaced by a second box with the image smoothly running its course in the background before looping over.

I cant seem to find a way to create a (start) button that 'dissolves' the intial text box and fades in another (note:id like a button to be pressed when peple have read the content)

 

As the video is running (ive set it to 'rest of project'), i thought maybe creating the 2nd slide and adding the content to that would be the fix... however, while the intial text box disappears, the textboxes on slide 2 will not show. 

 

im a beginner so i might be biting off a little more than i should but, id have thought this would be relatively easy however, i cant find a solution.

 

Any help / appreciated. im using Captivate 2019 release if that helps... let me know if any further details required! many thanks!

 

TOPICS
Advanced , Advanced actions , Audio and video , Editing , Getting started

Views

47

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

There have been many releases under the common name 'CP2019'. The most recent version for Windows is 11.5.5.553. Can you check your version under Help, About Captivate?

You inserted the video as slide video I suppose? How did you try to have the first text fading out, using Effects? Since you want to do it with one button, you have probably created an advanced action, using custom effects. Can you post a screenshot of that action?

The button can be pressed any time, which means it shouldn't have a pausing point. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Hi Lilybiri,

 

many thanks for your response - i can confirm it is the version you mentioned in your previous message.

in all honesty, im not sure how to approach the function in the best way... i tried using the 'states' but thats not really getting the desired efffect im looking for...

im not great at the advanced actions but i did attempt it and whilst the advanced action 'removed the initial box, the second one didnt come up at all...

this is where i thought, well maybe, if i use the button to 'jump to slide' and have the second box there, thatll look ok... however the box does not come up. i have found a way around it as such... but this means the bakcground slide video restarts at the new slide which does not look good at all.

 

see attached advanced action (i know its too simple to work) and an ides as to what the slide looks like.... its simply a moving image background.... 2 text boxes..... one i want to fade in initially on entering the eleanring project, and on selecting the start button, it fades out, before the 2nd box appears.

 

I hope that helps but any further info required, please let me know

 

cheers 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

You will not have a good Fade out/Fade in effect with that advanced action. Of course with a multistate object you cannot have any fade in/fade out effects. That is the reason I thought you had created a custom effect (using Alpha From To for both shapes). To apply that effect from the advanced action triggered by a button you can use Apply Effect command. I have a description of the workflow for a custom effect to be used in an Advanced action in this blog:

http://blog.lilybiri.com/how-to-use-custom-effect-in-actions

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Hi Lilybiri,

 

thank you for the prompt response - this has been a help.... can i ask - 

 

I have applied the following to the start button (see pic).... and it works in that it fades out the initial text box and some some other bits on the screen that are no longer required....

How can i now, if possible, make the advanced action fade in a new text box (possibly a second or so after the intial one has disappeared?

 

Id like to use the same start button if possible although with a changed state (showing 'next' or >>) somthing like that

 

many thanks, 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

For whatever reason, that advanced action as showing is now ot working, clicking the start button does not remove the initial text box or any of the items for that matter :S

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

LATEST

You can use the Delay Next Actions before adding commands to apply an effect to the second one.

If you have 3 objects which need the same effect, why do you not group them and apply the effect to the group?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines