• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Popup blocker message

Community Beginner ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

Hi

Since moving to Captivate 2017 we have started getting this message come up when a learner selects a link to a pdf (that is either on our website or in our online knowledge repository. I have checked using IE11 and Chrome - made sure the pop up blocker is off - but still get this warning. I'm certain the popup blocker is off because our LMS uses popups and I wouldn't be able to see the module at all if they were still on

The pdf tab opens ok but this message is making our learners a little unsettled. Anyone else experience this? Anyone know if there is a setting in Captivate that needs to be ticked/unticked?

TOPICS
Editing , Getting started

Views

7.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

Can you show a screenshot of the error message?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

warning message.png

Here's a screen shot of the message

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

That looks like a message that is generated from the Captivate project itself, rather than the browser. It might be invoked by an Advanced Action.

I suggest you go to Project > Advanced Actions and look through the Advanced Actions listed as used in the project and see if there is one that is executing some JavaScript to show an alert box.  If you find one, check the Usage to find which slide it is used on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

I'll check that Rod but this issue is now happening in at least three of our modules and I know for sure that two of them do not have a JavaScript command to show an alert box. The link has been put in two different ways in two different modules:

1) Smart shape as a button with an action 'On success open URL or file'

and

2) as a hyperlink "Open a file' and then pasted in the url that the file was sitting at

and we are getting the same message.

I agree it does look like a Captivate generated message and the actual colour changes according to the skin settings that we have chosen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2017 Sep 19, 2017

Copy link to clipboard

Copied

Just to add to your last comment; the style of the Runtime dialog box is part of the theme. You can find it in the Object Style Manager. A theme has several components, object styles and skin are two of them. More info:

What's in a Theme - a Template? - Captivate blog

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2017 Sep 19, 2017

Copy link to clipboard

Copied

Thanks Lilybiri -

I am wondering if this is a bug because I if I check theCaptivate 8/9 version of the module this pop-up message does not happen. When I open it ,save in Captivate 2017 and then publish  the pop up occurs.

What do you experts think? And if it could be a bug how do I let Adobe know?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2017 Sep 19, 2017

Copy link to clipboard

Copied

You are the first to report this (I am daily on this forum), not sure if it is a bug, or something is awry in your setup. But here is a link to the form:

bug report

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2017 Sep 20, 2017

Copy link to clipboard

Copied

Hi Lilybiri

When you refer to 'awry in your setup' are you meaning the captivate install itself? Or some other aspect of my computer setup?

I've now produced a test module just a couple of screens with a smart shape as a button with an action 'On success open URL or file'

and  a hyperlink "Open a file' and then pasted in the url that the pdf file was sitting at.

Even when I run preview as project (not loaded into our LMS) I still get this pop-up blocker warning. As you can see from the screen shot below the pop up blocker is not on

warning2 showing blocker off 210917.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2017 Sep 21, 2017

Copy link to clipboard

Copied

I tried to explain that since this is the first time I heard about such an issue, it seems to be something specific to your system/setupµ. That makes it tough to try to help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

popup.PNG

Same issue over here. Hyperlink text is opening a PDF in a new tab. The PDF opens fine, but the popup blocker message appears in the original tab. Also, "goto" is not a word.

It also happens if you use a click box to open the PDF url.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

We've found that if you use Google Chrome as the browser the popup doesn't appear

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

If only the government LMS liked Chrome.

We have to use Internet Explorer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

I think this warning message about popup blockers must be something new that has been added to Captivate's underlying codebase in recent versions.  The code must be able to detect that the browser being used has popups blocked and, since this can present a problem for some LMSs, the dialog box is invoked to tell you what to do.

I don't remember ever seeing this warning message in years gone by.  But the fact that it is now being suddenly reported by multiple developers, WITHOUT having made any changes to the e-learning courses being delivered from their LMSs, would seem to indicate that something has changed elsewhere.  My guess would be that the previously dormant code is now being activated by some change in the web browsers.  Perhaps a recent update to the web browser of choice has enabled popup blocking by default, whereas the previous browser setting was to ENABLE popups.

Try getting your end users to check their browser settings to see if popup blocking is ON or OFF.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

Our LMS uses popups so if the block were on you can't even see the Captivate module! So we did also double check and every time we find popup blocking is off, yet when pdf links and some hyperlinks within the module are accessed via IE11 we get this warning.

I am assuming a browser update is causing some sort of incompatibility and triggering this warning when it shouldn't. As I mentioned in a previous post Chrome does not seem to have this problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

We're going with the simple workaround of adding the current version of the PDF to the course folder. The popup doesn't appear that way. It's unfortunate since the document in question gets semi-frequent updates which would be no problem if we linked to the site where it lives.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

If adding the PDF to the course folder and linking to it via a relative link makes this warning message go away, then it would appear (to me) that the IE browser version updates are now configured to see linking outside to a PDF as a security violation.

Security warnings or blocks can be triggered by conditions that are regarded as cross-site scripting or XSS for short.

Cross-site scripting - Wikipedia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 22, 2017 Dec 22, 2017

Copy link to clipboard

Copied

We are experiencing this same issue since upgrading to 2017.  In fact, we've found it happens in IE 11 or MS Edge.  No issues with Chrome.  Wondering why!?  Any inputs?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2017 Sep 26, 2017

Copy link to clipboard

Copied

I have the same issue on Captivate 2017. When I run index_scorm.html (or index.html) from any browser I also get a popup (html5 output only). I can obviously block the popup, but I don't know why there is a popup. This is apparently causing bookmarking errors with my client.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

I'm having the same problem pop up blocker error message when the user clicks on a link that is an advance action of a link that loads in a new window. I have to provide links this way because the user has to click the exit button on the course to get credit for the course.

Has a solution been figured out?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

I don't think there is any way to code something that automatically disables the popup blocker.  That would be something hackers would LOVE to do. 

This issue with the popup blocker has only surfaced very recently and is probably the result of a recent browser update where popup blockers are ENABLED by default with the update.  Your end users may need to manually turn their popup blockers off.  And I think they may now need to specifically do it for each domain. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2017 Dec 18, 2017

Copy link to clipboard

Copied

Hey Rod,

                Unfortunately we are experiencing the same issue here as of recent (Captivate 2017). I think this appears to be an issue with captivate itself not wanting to play ball with Internet Explorer. Has anyone heard any more?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2017 Dec 18, 2017

Copy link to clipboard

Copied

Are you publishing to HTM/SWF or HTML5?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2017 Dec 18, 2017

Copy link to clipboard

Copied

Hey Rod, we are publishing it as just html, thanks for the fast response

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2017 Dec 18, 2017

Copy link to clipboard

Copied

OK.  Then are you also setting the Quiz > Reporting to ON for SCORM?

I'm asking because when you try to run SCORM content locally it DOES launch another window (i.e. a popup) looking for an LMS, and this might be triggering the popup blocker message or causing the content to fail to load.  So, if currently you have it set up for an LMS, try turning off the Quiz Reporting and republish.  Then you shouldn't have a popup to block.

The other thing to consider here is that HTML5 content really needs to be tested in a web server environment.  Some browsers (e.g. Chrome) are more forgiving and will allow you to launch the content without a web browser.  But for some reason Microsoft browsers with their increased security settings will not.  So you may need to upload the content to a web server to get a proper idea of whether things are working correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines