• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Publishing and Previewing in CpC 11.8.2 is broken

Community Beginner ,
Aug 18, 2023 Aug 18, 2023

Copy link to clipboard

Copied

I can't tell what has changed or when exactly, but I can no longer Preview HTML5 in Browser, and my published courses refuse to load in Chrome (normally I can open the index_scorm.html file and just ignore the warning about the LMS Driver not loading). I'm using Captivate Classic 11.8.2.254 on Windows 11, and both of these functions have been part of my workflow for a long time with the some of the same projects for which they now don't work.

 

When I use Preview HTML5 in Browser, I get the "Generating..." popup like normal, but then after a couple seconds, I get the error popup that I've attached a screenshot of, "WINWORD.EXE - Application Error   The application was unable to start correctly (0xc0000142). Click OK to close the application." The same error popup appears after I Publish the project to my computer and click to view the output. 

 

Viewing the .html file that results from publishing takes forever to load, but once it does, only a few images are visible, and the console is filled with hundreds of "Failed to load resource:..." and "**** drawing failed. img incomplete..." errors.

 

Please help!

TOPICS
Advanced

Views

168

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 19, 2023 Aug 19, 2023

Is it possible that you included a link to an MS Word document in your course materials?  If so then it would be trying to open MS Word to open that file.

It could also be that there has been a change to the default application settings on your computer and it now believes that HTML or HTML5 files should be opened by MS Word.  You should be able to check by going to Windows Settings > Apps > Default Apps.

Votes

Translate

Translate
Community Expert ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

Strange that the error is referring to Word. Did you update the Word application?

I can only recommend to try the usual troubleshooting workflows: clear the cache, clean the Preferences. More in:

https://blog.lilybiri.com/tips-for-troubleshooting

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

Thanks for the response and link to clearing the cache and preferences, I've used that to fix other problems in the past, but this time it didn't help. RodWard's suggestion to change the default application fixed the previewing in browser issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

LATEST

Sure, I didn't suspect that you linked the html filetype to Word, never used Word for website creation.

Local viewing of the HTML output works sometimes but it depends on which functionality you used in the project. As you pointed out, the only time when it is always functional is when you get the invitation after publishing to a non-zipped output folder. I use a webserver to test the non-SCO output.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

Is it possible that you included a link to an MS Word document in your course materials?  If so then it would be trying to open MS Word to open that file.

It could also be that there has been a change to the default application settings on your computer and it now believes that HTML or HTML5 files should be opened by MS Word.  You should be able to check by going to Windows Settings > Apps > Default Apps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

Changing the default application settings fixed the preview issue!

 

I had been using Word to create websites that I imported as web objects in Captivate to get a good scrollbar into some parts of my courses and I guess in that process, .htm files were set to MS Word, while .html files were still set to Chrome. After setting the default app for .htm files to Chrome, previewing in browser works again. Thank you!

 

I'm still having issues viewing the published index webpage file directly unless Captivate's local server thing is running (like clicking to view the output after publishing). I figured the LMS reporting might be causing it but even publishing a version with reporting disabled gives me the same issues I noted in the original post. This isn't the end of the world because they still work when being hosted on Scormcloud and I can now preview them, but it's a weird new problem, I have had no issues viewing those pages in the past.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Help resources