• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Text spacing suddenly stopped working in Adobe Captivate

New Here ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

My problem: text spacing started acting weird suddenly in Captivate. If I copy and paste or create any new object which includes text (text caption, smart shape, duplicate slide), Captivate adds more space between the lines than it should. This happens both in older projects or in completely new ones. In an older project I can have text boxes etc. that look normal, but when I copy and paste them inside the project, the spacing changes.

 

In the properties window under "Character", the spacing says still 1 pt for both the original and copied text, even though it is clear that the copied text does not have 1 pt. What is more, if I "change" the orignal text's spacing under "Character" to 1 pt (meaning: I just write the number 1 again to the field), the same space-magic happens: Captivate adds space between lines so that the original text is now similar as the copied text in terms of spacing, even though I didn't actually change anything.


I have attached a picture of the original text (above) and the copied text (below), so you can see how space is added between the lines.

 

So, if I have a project and I want to add or change a text caption or a box, extra space is added to all text. This happens too when I duplicate a slide, the new duplicated slide has all the text elements changed in it. Same goes with a smart shape with text in it.

 

For the life of me, I cannot figure out why Captivate does this. I had the same problem couple of weeks ago, but it just went away on its own during night and I figured it was just a weird glitch. Now, this has been going on for several days and I fear that this might be permanent if I don't find a solution.

If anyone has any ideas how this problem could be solved, I am thankful.

Views

193

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

I couldn't see the pictures, so here they are again:

character.JPGSpacing.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

I avoid copy/paste whenever possible. Did you edit the object style for the shape or the caption? Spacing is part of the style. Good practice is to use styles, which are part of the Theme. 

However this is very weird, and seems more like a corruption.

Can you check if it happens with the same theme in a brand new project? In that case corruption is probably in Captivate's Preferences. Find the subfolder 'utils' under the installation folder. Run the file CleanPreferences... which fits your OS while Captivate is closed. Restart Captivate and check if the issue is gone.

It is also possible that the theme is corrupted. Is this one of the themes packaged with Captivate? Did you edit and save the theme as a custom theme? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2020 Oct 14, 2020

Copy link to clipboard

Copied

Hi Lilybiri,

 

thank you for your response! If you mean that if I edited the style in Object Style Manager, then no, I have not edited/changed anything there for a long time. I went there to look for an answer to this problem, but the spacing was set to 1 pt there as well. 

 

The only things I have edited in this case are the "Character" features found in the Properties window, mainly font size or text orientation inside the caption box/area. I have not changed or edited anything in "higher level" settings, like an overall style for certain objects.

 

The same problem happened when I opened a new, blank project. I had another person test my project with their Captivate, and they did not have the same problem, the spacing worked as it should. Also, in their project, the "normal" spacing showed to be 1.2 pt, even though in my project the same text showed 1 pt spacing in Properties window. 

I ended up installing Captivate again, which seems to have removed the problem, but I still don't know what was the root cause of this weird spacing thing. If I encounter this thing again, I will try your CleanPreferences tip.

After re-install, I could also see that the text spacing in my project was actually 1.2 pt and not 1 pt as it showed earlier. 

Weird! 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Try selecting all the text and cutting it from the shape or caption. Paste it into Notepad or TextEdit to remove any and all formatting and then copy and paste it back. Be sure to press CTRL+A / Command+A to ensure you are pasting over any of the original formating that may get left behind.

Here's a tip if you happen to be a Windows user. I install a program called PureText, which is available in the Windows Store and is completely free. This program runs in your system tray and allows you to strip out any and all formatting copied from the original source material. You can set a special keyboard shortcut to have it work with the same number of keystrokes as a normal copy and paste. I use the Windows key plus V to paste from PureText. It's one of the half dozen or so items I always install on any new computer I use for work.

Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2020 Oct 14, 2020

Copy link to clipboard

Copied

Hi Paul,

 

thank you for your answer. I tried your pasting tip, but it didn't work. Also, I was already using Notepad when pasting text to Captivate, to remove any formatting the text might carry from its original source. It didn't matter where or how I pasted the text, the extra spacing was always added.

 

However, I noticed that in an older project where there were texts with correct spacing, if I copied their appearance (Copy Appearance) and pasted it (Paste Appearance) to the new text  that had weird spacing, the spacing was fixed. The spacing was reduced to what it should have been. But still, the spacing showed to be 1 pt even though it visibly changed.

That PureText tip is good, I will try that in the future as well.

As I said in the comment to Lilybiri, I installed Captivate again and this removed the problem. I do not know the root cause to the problem, however, so if there are any ideas or thoughts on this I'm interested to know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 14, 2020 Oct 14, 2020

Copy link to clipboard

Copied

LATEST

There is a feature related to kerning inside Captivate that could be the problem. To use this feature select some text and hold down Ctrl+Alt and press your arrow keys. Left and Right will increase or decrease the spacing between characters while the Up and Down keys will increase or decrease the spacing between lines of text. This is separate from any line spacing that is set. It's worth a try to see if this has been inadvertently used on some of the content.

Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines