Highlighted

An error has occurred: Error - unable to acquire LMS API and YouTube issue

New Here ,
Aug 11, 2020

Copy link to clipboard

Copied

I have a couple of issues with captivate program on my macOS Mojave (10.14.6):

1. My client wants something simple with mobile responsive - Just read each slides, watch videos, and tick the box after they have read the policies before go on next slide etc. When I published, open the file and pop up says "An error has occurred: Error - unable to acquire LMS API. content may not play properly and results may not be recorded. Please contact technical support."
Screen Shot 2020-08-12 at 3.54.33 pm.png

Screen Shot 2020-08-12 at 4.46.03 pm.png

2. When I test the slides, YouTube appear working just fine but when I publish the LMS and youtube didn't appear.

I hope anyone can help me with these issues.

   

Topics

Audio and video, Import export, Quizzing and LMS

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

An error has occurred: Error - unable to acquire LMS API and YouTube issue

New Here ,
Aug 11, 2020

Copy link to clipboard

Copied

I have a couple of issues with captivate program on my macOS Mojave (10.14.6):

1. My client wants something simple with mobile responsive - Just read each slides, watch videos, and tick the box after they have read the policies before go on next slide etc. When I published, open the file and pop up says "An error has occurred: Error - unable to acquire LMS API. content may not play properly and results may not be recorded. Please contact technical support."
Screen Shot 2020-08-12 at 3.54.33 pm.png

Screen Shot 2020-08-12 at 4.46.03 pm.png

2. When I test the slides, YouTube appear working just fine but when I publish the LMS and youtube didn't appear.

I hope anyone can help me with these issues.

   

Topics

Audio and video, Import export, Quizzing and LMS

Views

40

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 12, 2020

Copy link to clipboard

Copied

If you configure a project as a SCORM and then test it locally (not by uploading to an LMS) then you will see the Error about being unable to acquire the LMS API.  That's just telling you that it can't detect any LMS to talk to because you don't have one loaded on your local system.  Upload the same SCORM to SCORM Cloud and then it would be happy.

 

Not being able to get Youtube working when your content is being launched from an LMS is likely to be due to the fact that YouTube is blocking the link because it thinks another web domain is playing content that it doesn't have permission to play.  You need to check with YouTube or use a different streaming video provider.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

Hello Rob,
Thanks for respond to my post. Make sense about error about unable to acquire the LMS API.

YouTube videos are under my client's user and all videos are public. I tried other way with vimeo and doesn't work - When I upload the url link and been stuck loading half way for half hour. Do you have any suggestion for straming video provider or other way around?

 

Screen Shot 2020-08-13 at 11.13.53 am.png

Screen Shot 2020-08-13 at 11.15.21 am.png

  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 12, 2020

Copy link to clipboard

Copied

No.  In my experience these types of issues are due to YouTube blocking the content from playing within another domain because it thinks someone is stealing the content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

This is unusual about YouTube blocking the content from playing within another domain.

My client attempted to upload the zipped file to the LMS and kept getting and error message “Error while importing course”, so was unable to test the module.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
RodWard LATEST
Adobe Community Professional ,
Aug 12, 2020

Copy link to clipboard

Copied

It might be an issue on your own LMS.  Try uploading to SCORM Cloud to test and compare.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group