Highlighted

YouTube videos not loading in Captivate

Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

We usually don't link to YouTube videos in our training, but we have a client that needs us to link to one. It works when I run it locally, but once in the LMS, it just shows that it's loading and never plays.

 

Any ideas as to what is going on? Here's a screenshot of the videos and the Captivate Properties panel for the video. I am not using overlays.

 

youtube-not-working.jpg

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

YouTube detects when its content is being played from a different domain and usually blocks it.  When you are just playing it locally from your own PC, that's not a problem.

 

Check with YouTube about their permissions with this kind of usage.

TOPICS
Audio and video

Views

58

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

YouTube videos not loading in Captivate

Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

We usually don't link to YouTube videos in our training, but we have a client that needs us to link to one. It works when I run it locally, but once in the LMS, it just shows that it's loading and never plays.

 

Any ideas as to what is going on? Here's a screenshot of the videos and the Captivate Properties panel for the video. I am not using overlays.

 

youtube-not-working.jpg

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

YouTube detects when its content is being played from a different domain and usually blocks it.  When you are just playing it locally from your own PC, that's not a problem.

 

Check with YouTube about their permissions with this kind of usage.

TOPICS
Audio and video

Views

59

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 01, 2020 0
Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

Forgot to add I'm using Captivate 2019 Version 11.5.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0
Adobe Community Professional ,
Oct 01, 2020

Copy link to clipboard

Copied

YouTube detects when its content is being played from a different domain and usually blocks it.  When you are just playing it locally from your own PC, that's not a problem.

 

Check with YouTube about their permissions with this kind of usage.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0
dastie LATEST
Explorer ,
Oct 02, 2020

Copy link to clipboard

Copied

Yes, that explained it. This YouTube video is not owned by the client - it is a person with many subscribers who probably does not want their video used without consent.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2020 0