Transparent Back Ground Not Working Whatsoever.

Community Beginner ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

First of all, I am trying to use  Dynamic link into after effects. The character animator transparent background is checked. I have made my background the transparent choice on the scene panel. The default background exports in dynamic link. 

 

Or if I use media encoder the same thing. I am getting so sick and tired I have done everything on these forums. 

 

I'm paying every month for straight garbage. 

TOPICS
Bugs

Views

86

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Can you share some screenshots? I don't use dynamic link myself much, but always just dragged it in. The background is transparent by default. So not sure what flags you are setting. When using Media encoder, are you using a video format that supports transparency (alpha)? See the "export media with transparency" option in the menu. Most video formats do NOT support transparency, and even when they do, many video playback utilities turn transparency into black or white. So it can ge confusing. After Effects and Prem Pro etc do understand transparency.

 

What I don't understand is "default background". Personally I create puppets, and I draw images etc for backgrounds which I import as a separate puppet. Do you have the background image in the puppet itself? That can work, I just don't do that myself. A screenshot of the rigging hierarchy of your puppet might help.

 

(Friendly bit of advice - these are community forums, end users like yourself helping out others in their spare time. Adobe staff lurk at times as well. We all get frustrated with the software at times. I tend to see fewer responses for people complaining because they do not understanding something yet. I have been doing a project with 3D. After 2 YEARS I am about ready to publish my first few minutes of content. If you think Character Animator is frustrating, try 3D for animation! Ch is bliss in comparison.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Okay so. Specifically, when it comes to using a media encoder I have followed your steps from another post where you commented. I have been playing around with problems a little bit. 

 

With my older generated puppets it works fine, the nine yards media encoder export and dynamic link. 

 

I am in no way able to commit the time to make a puppet from scratch and I do not have the art skills. I am more of a video editor. For that reason, I am using the puppet maker tool. I am using the tool inside the character animator that makes puppets from the pre-designed templates. 

 

Now I have started running into a new problem with characters that I generate from puppet makers they sometimes do not have a mouth. 

 

I'll attach some screenshots. From my understanding, the background on the puppets from the puppet makers is somehow integrated into the character themselves. In the timeline, the background doesn't show up as a separate layer it's just there. 

 

That's fair enough I spent about a month doing 20 seconds of footage in after effects. The difference here is that to me this feels like the software is broken rather than a steep learning curve. 

 

Thank you for taking the time to reply to this. I have read many of your answers in other threads. Adobe should hire you.

The reason I am so frustrated is that some of the answers the adobe team provides here seem to be full of rudeness. Some of them read as everyone should be born with a complete understanding of how assembly works all the way to the end-user interface. 

I am not completely new to adobe I have been using their creative products for almost 17 years.

In the distant past, I animated using Flash. 

 

System Specs:

Windows 10

Gigabyte Mother Board 

CPU: Intel Core i3-6100 CPU @ 3.70GHz 

GPU: Zotac 1050 Ti

8 GB of Ram. 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Yes, it looks like Puppet Maker (Characterizer?) includes the background image in the puppet. Unfortunately the screenshot chopped off the full rigging hierarchy, but the rig panel shows the background. This is not necessarily "wrong", but I have never done it that way. E.g. how to include two such characters in a scene? As soon as you add them both to the timeline, the background of the puppet in front would hide the other puppet - if you need a scene with both characters in it.

 

I don't have time to try Characterizer just now (heading off to bed). Does it create an Illsutrator / Photoshop file for the puppet? Or is it doing "magic"? If you do "Edit Original" from the menu in rig mode, does it start up Illustrator or Photoshop? Personally I would delete the background image in the artwork file. (I am assuming you don't want the background as you are talking about transparency?) But not knowing characterizer, I don't know if this will work. No idea why the mouth sometimes does not appear. If you can repeat it, we can look at digging into the rigging hierarchy. If there are lots of triggers and things going on, it might be something in that area. But step #1 for me is to work out if Characterizer generates "normal" puppets or are there special rules for them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

LATEST

After reading your posts I went into the rigging and deleted the foreground and background in rig mode seems to work. 

 

I just cant seem to get mouths on some of my characters. In the images attached above check the scene version versus the rig version of it. No mouth in the scene version. 

 

I don't understand why using this software feels like I go from one complex issue to another. 

 

Thanks again for your input. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines