CF2021, new install but wsconfig not working

New Here ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

Hello,

 

Been digging through the docs the last few days and i'm about out of hair to pull out.

 

I've been leveraging the zip file based distribution of CF2021, have it up and running without any aparent errors in the server on a Windows 2019 Server. However, when I go to utilize the wsconfig utility I get the following error and honestly, i'm just sitting here spinning my wheels trying to figure this out.

>C:\ColdFusion2021\cfusion\runtime\bin\wsconfig
Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\ColdFusion2021\config\wsconfig\cfwin32.dll: Can't find dependent libraries
        at java.base/java.lang.ClassLoader$NativeLibrary.load0(Native Method)
        at java.base/java.lang.ClassLoader$NativeLibrary.load(ClassLoader.java:2430)
        at java.base/java.lang.ClassLoader$NativeLibrary.loadLibrary(ClassLoader.java:2487)
        at java.base/java.lang.ClassLoader.loadLibrary0(ClassLoader.java:2684)
        at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2617)
        at java.base/java.lang.Runtime.load0(Runtime.java:765)
        at java.base/java.lang.System.load(System.java:1835)
        at com.adobe.coldfusion.connector.connectorinstaller.Win32Handler.<init>(Win32Handler.java:51)
        at com.adobe.coldfusion.connector.connectorinstaller.gui.ConfigFrame.<init>(ConfigFrame.java:67)
        at com.adobe.coldfusion.connector.connectorinstaller.gui.ConfigFrame.run(ConfigFrame.java:536)
        at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstaller.java:991)

 

Note, this is a brand new server and has never had another instance of coldfusion installed on it. The dll referenced IS there, so i assume its something in the DLL that's not on the system when it's expecting it.

 

I would appreciate any help and guidance the community may have.

TOPICS
Getting started

Views

119

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Guide , Jan 26, 2021 Jan 26, 2021
Found that vague here this bit: https://coldfusion.adobe.com/2020/12/coldfusion-2021-install-experience/Webserver configuration The 2012 VC runtime is needed for connector configuration and for the HTMLtoPDF module. As this runtime is not bundled by default in the ZIP installers, you will need to set it up first before you can either configure your connector or use the HTMLtoPDF functionality or both. You can download the 2012 VC Runtime from here https://www.microsoft.com/en-in/download/details.aspx?id=30679

Likes

Translate

Translate
Guide ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

Hi Brad,

I have a vague reminder come into my head about the ZIP installer not including the Microsoft Visual Redistributable. I wonder if you separately add that component if WSCONFIG will work?

While I am using ZIP installer in a Windows 2019 environment I had Graphic install on first before uninstalling - so for now unable to emulate issue.

You are doing WSCONFIG as admin right?

 

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

Found that vague here this bit:

 

https://coldfusion.adobe.com/2020/12/coldfusion-2021-install-experience/

Webserver configuration

 

The 2012 VC runtime is needed for connector configuration and for the HTMLtoPDF module. As this runtime is not bundled by default in the ZIP installers, you will need to set it up first before you can either configure your connector or use the HTMLtoPDF functionality or both.

 

You can download the 2012 VC Runtime from here https://www.microsoft.com/en-in/download/details.aspx?id=30679

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

LATEST

Sigh. This is what I get for staring at docs for hours. I saw that, many times in fact, looked at appwiz and saw 2015-2019 redistributable and just never connected the two. My savior, I appreciate you taking the time to answer such a silly question.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines