• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

ADE crashes when opening ACSM file in Windows 10

New Here ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard


Whenever I try to open ACSM files in ADE it crashes/becomes unresponsive and the only way to close the program is using the Task Manager or restarting the computer. Once it's been closed and re-opened my book still isn't there are attempting to open the ACSM file again causes the same crash. I've tried the most recent version as well as v3.0 and v2.0.1. I've tried uninstalling and reinstalling, de-authorising and re-authorising with my Adobe ID, deleting or renaming the "My Digital Editions" folder, running ADE as an administrator, running ADE in compatability mode for previous versions of Windows, installing to Program Files instead of the default Program Files (x86), installing to D drive, and installing in a new Windows user profile. I've tried ACSM files from two different sources. I'm running Windows 10 Home (64-bit). Any help is very much appreciated because I cannot use my eReader as I want to without being able to open these ACSM files in ADE!


I recently got an eReader as a gift which I chose because it was compatible with my local library's eBook options - but I can't get it to

ACSM files






Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation