DRM authorization prevents copying book to Kobo ereader

New Here ,
Nov 06, 2020

Copy link to clipboard


I downloaded a book from my public library.  Actually I tried from three different libratries where I have accounts.  When I tried to copy from Adobe Digital Editions to the ereader, it seemed to work.  Attempting to open it to read it on the ereader gave me an error message that I didn't have authorization because of the DRM protection.  I deleted it from the reader and tried to download again ,but it wouldn't transfer like it had the first time.  The procedure found in help told me to erase the authorization and re-authorize the computer.  When I ttried to erase the authorization, I found I couldn't because the password wasn't recognized.  Changing my password didn't solve that.  A long on-line chat with Farhan (who initialy told me that there was no account associated with my email) got me through the erasure of the authorization, but now that I have re-authorized, the authorization isn't recognized and I can't access my library download.  Farhan didn't have any other ideas except to post in the forum.   Here I am with my tale of woe and little hope of ever reading again.








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation