Will not open E-Book

New Here ,
Mar 19, 2018 Mar 19, 2018

Copy link to clipboard


I’ve been trying to view my school textbook on my iPad and it wont open. So I uninstalled the app, reinstalled it, and same thing. So I deleted the book, and tried to reinstall it, and I have to reactivate the app. Wouldn’t be a problem if it would work! I type in my username and password and the dial just spins for hours. So Ive tried retstarting my iPda, I’ve tried it with and without wi-fi.. Nothing seems to work. Then, I saw on a previous forum to change the date to earlier than today, I did that, and can now view the “get started” on adobe, but still cant activate the app to download the textbook I need.. I keep getting an error message that reads, “Digital Editions encountered an error while activating”. And thats it. I need this book for my school notes and to study!! Please help!








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation