• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Add new PHP versions to Preferences

Community Beginner ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

Hello,

 

I'm trying to set a recent PHP version in my preferences, and the latest is 7.1... which is at the end of its life. 

 

Screenshot: https://app.screencast.com/jzRALZbpRKTiO

 

My code view shows the code having errors because it's too old. Is there a way to add more versions?

 

Thanks!

TOPICS
Code , Error , Extensions , How to , Other , Product issue

Views

142

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

Unfortunately DW is now in minimal maintenance mode so it is unlikely to receive these updates for PHP or other code such as Bootstrap. Your best bet would be to start evaluating replacements for Dreamweaver such as Sublime Text, Visual Studio Code, or Nova.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2024 Jun 09, 2024

Copy link to clipboard

Copied

Olá,

Será que ainda vão voltar a atualizar o DW com as funcionalidade voltadas para desenvolvimento em PHP > 8.0?

 

É uma pena que a Adobe não esteja mais atualizando o DW, sou usuário antigo desde o CS3/CS4.

 

Obrigado!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 09, 2024 Jun 09, 2024

Copy link to clipboard

Copied

LATEST

NO.

You should use a PHP IDE alongside Dreamweaver. 

  • VS Code from Microsoft.
  • PhpStorm from JetBrains.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

I kinda felt that as well. Not much love given to DW in the past couple of years. I've been using it since the Macromedia days! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

I use a PHP IDE alongside Dreamweaver. 

  • VS Code from MS
  • PhpStorm from JetBrains.

 

Hope that helps.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2024 Apr 12, 2024

Copy link to clipboard

Copied

Thank you! I may make a transition to something else... eventually maybe 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines