Dreamweaver CC 2020 running super slow

New Here ,
Apr 21, 2020 Apr 21, 2020

Copy link to clipboard

Copied

Hello, today is my first day using Dreamweaver CC 2020.

I have started alright, but then it starts to get very laggy and slow and eventually not responsive.

I would like to ask if anyone would have any advice or solution, or maybe I need to clean the cache please? However, I was just building my landing page and shouldn't have too much heavy loaded assets in my file.

 

Thank you ><

TOPICS
Performance , Product issue

Views

3.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

What OS are you using (type and version)?
Where are you storing your site's files (local drive, network, etc)?
Have you created a Site Definition within DW?
Are there any errors in your HTML (http://validator.w3.org/nu)?
Have you tried clearing the cahce, restoring preferences or reinstalling yet?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

Hi Jon,

 

My OSX is 10.15.4, and I am storing my site's files within my local drive.

I have created a Site Definition after your suggestion.

I have also tried restoring preferences, but haven't tried clearing the cache nor reinstalling yet.

 

I also have a 1.3MB video playing (which I have currently set in a loop), would that also be a problem for the slow performance? 

 

Cheers,

Karen

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 23, 2020 Apr 23, 2020

Copy link to clipboard

Copied

"I also have a 1.3MB video playing (which I have currently set in a loop), would that also be a problem for the slow performance? "

 

Disabling video while editing won't hurt.  Also try switching to Design view (see screenshot).

Document Toolbar > Design ViewDocument Toolbar > Design View

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

Please ensure your computer exceeds the minimum system requirements to run Creative Cloud+ all other apps you intend to use.
https://helpx.adobe.com/creative-cloud/system-requirements.html

 

Slowness can be related to many things.  My first inclination is to kill all non-essential background processes that might be competing with DW for resources.

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

I am having the same issue. Just typing in code view I have to wait for the cursor to catch up. My system is well above the minimum requirements, (see my Task Manager images attached). Every time I just make one character change in my code the app boosts my CPU usage an additional average of 4% - 6%. My RAM seems unaffected by this and I have plenty in reserve. I never had this issue before. Not until I updated to the last update of this app.

It seems that there is some kind of preprocessing, (Like Webpack) going on in Dreamweaver, which forces me to wait for the app to catch up every time I make the smallest change to my code. Even when I am not using Live view or using Dreamweaver to render the site in a browser.

 

This is unacceptable! There is no coder who is going to wait around for the cursor to catch up with the developer's typing using this app. If fact, twice I have moved my code to WebStorm because I got sick of waiting for my cursor to catch up with my typing.

 

By adding just one character to my codeBy adding just one character to my codeDetails of resources used by Dreamweaver after typing 3 characters of codeDetails of resources used by Dreamweaver after typing 3 characters of code

 

 

 

I have plenty of CPU resourcesI have plenty of CPU resourcesI have plenty of RAM resourcesI have plenty of RAM resources

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

I have the same exact issue.  I type a couple of characters and then there is a massive delay where I have to wait up to 5-10 seconds before I can type more.  The screen blurs for a second while it is waiting for the processing to catch up and displays "(Not Responding)" while it is waiting to catch up.  Extreme lag.  I have looked and updated my preferences but nothing is working to stop the lag.  Does anyone know how to solve this with Dreamweaver CC?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

I just found the answer on another post, please take a look here: https://community.adobe.com/t5/dreamweaver/adobe-dreamweaver-cc-is-super-slow/m-p/11386274?page=3

 

Deleting the "Temp File List" folder using regedit did the trick for me.  I have been searching for days for a fix and that is what stopped the lag.  Just thought I would share.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2020 Oct 18, 2020

Copy link to clipboard

Copied

I looked at the link but I'm confused...what does that mean? What is "Registry key press win +R -> type regedit"???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

-Close Dreamweaver.

-Hold down the Windows key and the "R" key on your keyboard.

-Type regedit, then hit Okay.

-Find: \HKEY_CURRENT_USER\Software\Adobe\Dreamweaver 2020\Temp File List\

-Right click on the "Temp File List" folder.  To delete it, click on the option: "Export".

(Save it to Desktop or other location you may choose.  Always a good idea to temporarily save that Folder with its files, as a backup just in case. I always keep them for a while anyway.)

 

-Start Dreamweaver. It will run much faster.

 

Dreamweaver will automatically re-create a new "Temp File List"  folder where it hold new temp files from using Dreamweaver.

Hope that helps.

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

THANK YOU!!!!!! That was so very specific and dumbed down for me. I
appreciate it! I was able to follow your directions and it worked! Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

Great! Glad to have helped out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Hi All,

 

We have addressed the slow typing performance issue in code view on windows in latest Dw 21.0 update.

Please update to latest Dw version 21.0 and let us know in case you are still facing the issue with Dw 21.0.

 

Thanks,

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

The Dreamweaver 21.0 update is working well and no slow typing issues.

Thanks for the new updated version!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

LATEST

Hi Freedom_421

Thanks for the confirmation that the issue is fixed for you.

 

Regards

Dreamweaver

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines