• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Dreamweaver CS6 "Find and Replace" not working

Engaged ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

Since I've started working in DW CS6 I've noticed that the Find and Replace feature isn't working completely.

E.g. If I select a block of code, then open Find and Replace, tell it to find "<br />" and replace it with "</li>" it only replaces the first instance. The rest of the <br />'s are still <br />'s.

Is this happening to anyone else? I may have to switch back to CS5.

Views

25.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Mar 19, 2014 Mar 19, 2014

Votes

Translate

Translate
Community Expert ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

I have no trouble with F&R in CS6.  What happens if you hit the Find All button?

Nancy O.

Alt-Web Design & Publishing

Web | Graphics | Print | Media  Specialists 

http://alt-web.com/

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

When I hit the Find All buttons the Search Panel gets populated with all instances of the tag I searched for.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

P.S. I'm on a Mac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

Mac, but which version?

Nancy O.

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

Which version of Mac? I'm on a 2009 Intel Mac Pro.

You wouldn't mean which version of Dreamweaver, would you? It's CS6 as stated in the title.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

I don't know if this is related to your problem but OSX Lion has an update that is recommended for stability.

http://support.apple.com/kb/HT5167

You can file an Adobe bug report below:

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Nancy O.

Alt-Web Design & Publishing

Web | Graphics | Print | Media  Specialists 

http://alt-web.com/


Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 21, 2012 May 21, 2012

Copy link to clipboard

Copied

Don't have Lion. Can't use all of CS5 in Lion, and I can't trust CS6 enough to switch.

I just reported it as a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 22, 2012 May 22, 2012

Copy link to clipboard

Copied

You are clicking the Replace All button (i.e. not Replace)?

And you have 'Find In' set to Current Document (i.e. not Selected Text)?

What version of Mac OS are you using? e.g. 10.6.8

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 22, 2012 May 22, 2012

Copy link to clipboard

Copied

Yes, I was hitting the Replace All button. And I had Selected Text selected (not Current Document).

I'm using 10.6.8.

...and I'm back to using DW CS5 (heh).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 22, 2012 May 22, 2012

Copy link to clipboard

Copied

I can confirm.  Windows 7 x64.  Exactly the same -- select a block of text, choose 'find in selected text', choose 'replace all', and only the 1st instance is replaced.  I forgot about that when reporting several other serious FTP-related problems I've been having with DW CS6 (see separate post).  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 22, 2012 May 22, 2012

Copy link to clipboard

Copied

Hmm. Just tested on 10.6.8, as well as on Windows 7 x64, but could not reproduce the issue.

I'd like to find out what's going on so we can get it fixed.

Could you share the code from one of your pages?

(Feel free to remove any actual content and/or simplify the page.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 22, 2012 May 22, 2012

Copy link to clipboard

Copied

Carey, I made you a screencast of the bug.   Check your messages.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 23, 2012 May 23, 2012

Copy link to clipboard

Copied

And here is one of the pages I was working on. I made a duplicate because I'm still working on the site.

http://eastcoastspas.com/NEWSITE/_hot-tubs/twilight_series_spas/for_adobe.php

At line 26 there are 2 unordered lists. Previously they were just lines with char codes for bullets and <br /> tags. I tried to use Find and Replace to change all of the bullet codes to "<li>". I already did it manually, but if were to try to change all the <li> back to char codes, it would happen again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2012 Jun 12, 2012

Copy link to clipboard

Copied

I can confirm this bug on two different Win7 machines (x86 and x64):

Original text:

          <ol>

                    <li>The quick brown fox jumps over the lazy dog.</li>

                    <li>Who's afraid of the big bad fox?</li>

                    <li>Fox starts with W.</li>

                    <li>This lady is foxy.</li>

          </ol>

Task: Replace all instances of "fox" with "wolf" on the the middle two list items by selecting the following text.


  <li>Who's afraid of the big bad fox?</li>

  <li>Fox starts with W.</li>

Output:

          <ol>

                    <li>The quick brown fox jumps over the lazy dog.</li>

                    <li>Who's afraid of the big bad wolf?</li> <!-- Replaced -->

                    <li>Fox starts with W.</li> <!-- Not replaced -->

                    <li>This lady is foxy.</li>

          </ol>

Expected:


          <ol>

                    <li>The quick brown fox jumps over the lazy dog.</li>

                    <li>Who's afraid of the big bad wolf?</li>

                    <li>wolf starts with W.</li>

                    <li>This lady is foxy.</li>

          </ol>

Doesn't work for both text and source code.

Is there a fix coming soon?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

** ANSWER/Workaround

Was having the same problem after updating from DW CS5 to CS6. Change the selection in the 'Search:' dropdown from the default 'Source:'  to 'Text' or 'Text (Advanced)' and you will get the desired result. I still do not undertand why 'Source' only changes the first occurence.

Message was edited by: bracdiver

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

bracdiver wrote:

** ANSWER/Workaround

But this doesn't work on code.

<p> </p>

<p> </p>

<p> </p>

<p> </p>

Select the code above, go to F&R

Find in: Selected text

Search: Text (or advanced Text)

Find: non-breaking spaces (the actual code)

Replace: some real text here...

Hit Replace All button.  Nothing happens.

Nancy O.

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

I agree - it's a limited workaround but effective for a lot of the work I do.Clearly, Adobe needs to address this promptly - it's a real gaffe and productivity killer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

No argument - just wanted to point out that text replacement is still a helpful feature simple cases. Did not intend in any way to absolve Adobe of it urgent obligation to get this working right. Chers!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2012 Jun 27, 2012

Copy link to clipboard

Copied

Same problem here. OSL lion with CS6. Do the people at Adobe even work with dreamweaver? This is not an exotic function.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

bracdiver wrote:

** ANSWER/Workaround

Change the selection in the 'Search:' dropdown from the default 'Source:'  to 'Text' or 'Text (Advanced)' and you will get the desired result.

bracdiver, your post may be useful in some examples, like the ones I posted above. However, this does not work in my intended example below (which is source code specific), where the actual source code needs to be replaced:

Sample

     

<p>These are true or false questions. Place your answer on the blank under each question.</p>

<ol>

    <li>There are twelve in a baker's dozen</li>

    <li>35% of people are going to school.</li>

    <li>There are seven books in the Harry Potter series.</li>

    <li>The longest running play is "Les Miserables"</li>

    <li>There is no blank under this question. <i>Answer beside this question instead.</i></li>

</ol>

         

Using these options

Find in: Selected Text (first four list items)

Search: Source code:

Find: </li>

Replace: <br />___________________</li>

Options enabled: Match case

Desired output:

<p>These are true or false questions. Place your answer on the blank under each question.</p>

<ol>

    <li>There are twelve in a baker's dozen<br />___________________</li>

    <li>35% of people are going to school.<br />___________________</li>

    <li>There are seven books in the Harry Potter series.<br />___________________</li>

    <li>The longest running play is "Les Miserables"<br />___________________</li>

    <li>There is no blank under this question. <i>Answer beside this question instead.</i></li>

</ol>

CS6 DW output:

<p>These are true or false questions. Place your answer on the blank under each question.</p>

<ol>

    <li>There are twelve in a baker's dozen<br />___________________</li>

    <li>35% of people are going to school.</li>

    <li>There are seven books in the Harry Potter series.</li>

    <li>The longest running play is "Les Miserables"</li>

    <li>There is no blank under this question. <i>Answer beside this question instead.</i></li>

</ol>

Using your workaround (with 'Inside Tag' option set to li), this will not work as does not change any text at all.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2012 May 25, 2012

Copy link to clipboard

Copied

Confirmed bug.

F&R on selected text doesn't work.

I hope an update soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2012 May 29, 2012

Copy link to clipboard

Copied

I appear to be getting this same error/bug.

Win7 with Dreamweaver CS6.

When I select a bock of code and try to "find in: selected text" and then "replace all" only the first instance is replaced.

I hope this is fixed asap, as this feature is a valauble one that I use on a daily basis in my work!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 29, 2012 May 29, 2012

Copy link to clipboard

Copied

I can reproduce this error.  Find and replace in selected text is only replacing the first instance of the search text.  I will report it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 04, 2012 Jun 04, 2012

Copy link to clipboard

Copied

I have this problem too. Mac 10.7.4 and Dreamweaver CS6. Using replace all, with selected text, only replaces the first instance.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines