• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Dreamweaver preview in browser not working Firefox 3.6 Mac

Contributor ,
Feb 03, 2010 Feb 03, 2010

Copy link to clipboard

Copied

Hi,

Preview in browser not working for Firefox - Mac. I'm guessing it could be somthing to do with my update to FF 3.6 as it was fine. The browser opens but the temp file does not show.

Anyone any ideas?

Rich

Views

33.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2010 Feb 03, 2010

Copy link to clipboard

Copied

I was able to fix the regular DW html preview bug by making sure local file paths followed path naming conventions. But, now I have a different problem; Firefox 3.6 will not display a DW preview of an html or php file from the localhost. I am using MAMP 1.7.2 on Mac 10.5.8. If I manually enter the path name in the address bar, Firefox will open the files. DW localhost previews will display in Safari and Opera.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 04, 2010 Feb 04, 2010

Copy link to clipboard

Copied

Same thing happened to me. The Preview in Browser from DW has stopped working in FF since upgrading to Firefox 3.6

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2010 Feb 04, 2010

Copy link to clipboard

Copied

Was reading a mozilla users thread about this; Firefox considers the new way better (no spaces or special characters in path names). I tried this, but still had problems. Don't look for a fix from mozilla as they think everyone else is out of step on this.

A suggested workaround is Automator. I tried the recipe suggested in the thread, but it didn't work. The poster insisted it should, so I looked at it closer, trying to find out why mine didn't. Then I hit upon this idea; I have my preferences set so that DW opens DW files whenever those files are double clicked, and, any html docs without the DW icon open with Firefox. Taking this into consideration, I came up with a recipe that works.

First, if you haven't already, set the default broswer in Safari's preferences to Firefox.

Open Automator and set up the following workflow:

Get Specified Finder Items - add the DW doc you want to preview in Firefox.

Set Application for Files - set Firefox as the application

Display Webpages - this opens Safari (or the default broswer set in Safari's prefences).

Save the workflow as an application (ex: StandardBrowser.app)

Add the new app to the DW browser list.

The path (Get Specified Finder Items) must be edited for each page you want to preview. I suppose you could create an Automator app for each page and add them to the browser list, but I prefer to just edit the Automator app for each page. Just reopen the app in Automator and add the path to Get Specified Finder Items.

UPDATE: I posted a copy of this at the mozilla users forum where I got the Automator tip. The poster replied that I had one step too many. You don't need the middle step in the workflow above. Also, he said on his 10.6 machine that step one will work just by itself and that step three will work just by itself. Neither one of the one step solutions worked for me (10.5). I updated my Automator app by eliminating the second step, and it's working just like the three step version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 15, 2010 Feb 15, 2010

Copy link to clipboard

Copied

Mason,

Thanks.  The Automator workaround works.  Still, its not a very satisfactory solution.  I'll be testing more in Safari until Adobe or Mozilla fixes this. I just hope we don't have to wait until CS5 or FF 4 for it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2010 Feb 18, 2010

Copy link to clipboard

Copied

This is not working for me, either. Which is a total pain, having gotten very used to checking, checking, checking.

Firefox, I'm saying goodbye. Adobe, I'm betting you're not totally innocent.

Hope it's soon that you guys fix this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2010 Feb 18, 2010

Copy link to clipboard

Copied

Also not working for me. What a bore. That work-around might work but who wants to build a new path for every document? Might as well just dump the file onto the icon manually, or enter MAMP URL by hand. I think I'll just switch to another browser for basic testing. Too bad I like all the toolbar add-ons etc for Firefox.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2010 Feb 19, 2010

Copy link to clipboard

Copied

If you create a site on the Desktop, the preview will work in Firefox  3.6. The site can be in another folder on the Desktop. The site name  cannot have spaces in the name, and if in another folder, that folder name cannot have spaces. Also, the testing server option must be set to none.

If you're writing php to a MAMP server, you have to navigate to the localhost files to preview in FF 3.6  You can then bookmark the files you're working on. Or, you can use Automator to make a  kind of bookmark to use in the DW browser list. I've been looking for an AppleScript that will do the same thing without having to enter a path name for each file. I've been scanning the add-ons at Mozilla and the extensions at DW exchange hoping someone will write a plugin for this, but so far no luck.

Firefox does not see this as bug, so don't look for them to "fix" it -- and 3.7 and FF4 are on the way. FireFox is cool,  but like I've read in other forums, if you're going force Mac  developers to choose between DW and FF, then Safari's Developer menu starts looking like a decent alternative to Web Developer and Firebug.

If you're addicted to those tools the way I am, then you should download Mozilla's SeaMonkey 2.0.2. It previews DW html and php with MAMP set as the testing server, and you can add Web Developer and Firebug extensions to SeaMonkey. Or, download FF 3.5.8

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2010 Feb 19, 2010

Copy link to clipboard

Copied

What a pain. Have wasted time this morning trying to get it to work and assumed it was something I'd inadvertently done. At least now I'm glad it's not just me (sorry guys). Life (and web-design) is complicated enough without having to do a work-around on something that worked perfectly well yesterday. Sorry, not a very constructive post but allows me to vent my spleen!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2010 Feb 19, 2010

Copy link to clipboard

Copied

Update: the site doesn't have to be on the Desktop, it just has to have no spaces in the path name and testing sever set to none. I read about the Desktop soulution in another froum. I tested it and it worked, but I should have tested it for other locations before posting. Sorry 'bout that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 23, 2010 Feb 23, 2010

Copy link to clipboard

Copied

Just read another post offering a suggestion to downgrade to 3.5.8.

http://www.mozilla.com/en-US/firefox/all-older.html?from=sfx&uid=300882&t=443

All up and running again with this version.

Rich

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2010 Feb 27, 2010

Copy link to clipboard

Copied

Just tested it on the

Desktop, but no dice.


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 11, 2010 Jul 11, 2010

Copy link to clipboard

Copied

Thank you!  My problem wasn't spaces in the path name, but in the

site name.  I removed the space and tried again and it worked.  Thans a lot!

This was driving me crazy!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 14, 2010 Jul 14, 2010

Copy link to clipboard

Copied

I can confirm too that removing spaces from the site name also worked for me and Firefox nows previews correctly.

However I don't see why I should have to change all my site names just to get Firefox to behave as the other browsers do already!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 14, 2010 Jul 14, 2010

Copy link to clipboard

Copied

While spaces in file/folder names are tolerated by many operating systems they have never been a good naming convention on the web.  Spaces are technically not-allowed so they get translated to %20 which  alters the URL. Use underscores, hyphens or a mix of upper and lowercase letters instead of spaces.

Nancy O.
Alt-Web Design & Publishing
Web | Graphics | Print | Media  Specialists
http://alt-web.com/
http://twitter.com/altweb

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 15, 2010 Jul 15, 2010

Copy link to clipboard

Copied

I quite agree about the effect of spaces in URLs but this is about the Dreamweaver site name property, not the URL used to preview.

Using "Preview in Browser" (Firefox) works even if the URL contains spaces but the Dreamweaver site name cannot have spaces.

If the site name is changed (Site -> Manage Sites -> Edit) and the new site name contains spaces, the "Preview in Browser" function stops working, even though the URL is still exactly the same.

Therefore I believe the site name has nothing to do with the URL used for testing but it does seem to break the function if the site name is not in a specific format. Also its worth remembering that this behaviour does not seem to happen in other browsers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2010 Mar 09, 2010

Copy link to clipboard

Copied

The solution I'm using is to make bookmarks in the FF toolbar for the pages I'm testing. Refresh, refresh, refresh. Simpler than automator.

This is a problem Adobe should address, though, or Firefox. I don't care who fixes it, but this really should work.

Ann

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2010 Mar 09, 2010

Copy link to clipboard

Copied

Ann,

That was an easy solution that was staring me in the face. Granted it's not as good as Adobe fixing things, but it feels less troubling than pimping out my mac with automator.

As it is, Dreamweaver has always been a bit buggy, and I don't expect much improvement.

Point of note:

Freeway by Softpress has no problem previewing in Firefox. Quark also previews in Firefox without a hitch. And neither of them crash half as much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2010 Mar 09, 2010

Copy link to clipboard

Copied

https://bugzilla.mozilla.org/show_bug.cgi?id=542903

https://bugzilla.mozilla.org/show_bug.cgi?id=530064

This bug is supposed to be fixed with the release of 3.6.2

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2010 Mar 10, 2010

Copy link to clipboard

Copied

Before you bookmark, you can just test in Chrome, Safari, or Opera, or IE if you're on windows, and quickly copy/paste the URL to FF if you have to use any of the 3rd party geegaws available there. I find reconstructing the path to a MAMP port location possible but a bit tedious.

As this problem was "ain't broke" until the FF fix came along, personally I choose not to blame Dreamweaver.

I would imaging the security fixes in the new FF are there for a reason, and so would rather not back-grade. Perhaps the security is the source of the problem? A balance of security vs. ease of functionality is always an issue, whether one is a software developer, or anybody who has a house or apartment with a front door. I look forward to the 3.6.2 fix mentioned by Mason above.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2010 Mar 22, 2010

Copy link to clipboard

Copied

I just updated to FF 3.6.2 with DW CS4 Build 4117, MBP OSX 10.6.2.

Still nothing!

Restarted, reset DW browser list - nothing.

Guess 3.6.2 is not the answer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 01, 2010 Apr 01, 2010

Copy link to clipboard

Copied

A few days ago (for reasons totally unrelated to the browser preview issue) I ended up reinstalling my operating system, upgrading to Snow Leopard and reinstalling CS4. So, of course, the Firefox install is 3.6.2.

And Firefox browser preview works in Dreamweaver CS4! Yay!  But I'm not sure what did it. Reinstalling everything is pretty drastic, and it's hard to say what part of it actually did the trick.

In any event, the browser preview does work if you get everything just right . Somehow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 02, 2010 Apr 02, 2010

Copy link to clipboard

Copied

Well I just updated to Firefox 3.6.3, but it didn't fix the issue for me.

No way I can afford the time to re-install the entire system right now, unfortuantely.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2010 Apr 12, 2010

Copy link to clipboard

Copied

Same thing here. The “Preview in Browser” in DW has stopped working in Firefox and does not work in Firefox 3.6.3. Removing spaces in the path name and setting “testing sever” to "none" does not work either.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 01, 2010 May 01, 2010

Copy link to clipboard

Copied

Hey all. It seems that the problem is fixed with Dreamweaver CS5 (trial) and Firefox 3.6.3. Although I am still holding my breath for my CS4 to work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines