How can i make code completion work for PHP included files?

New Here ,
Mar 28, 2019 Mar 28, 2019

Copy link to clipboard

Copied

Hello,

I have a question about auto code completion feature. I am trying Dreamveawer 19.0.1. I am working on a PHP project. My pages have "header.php" and "footer.php" included at certain places. I am also using jQuery and Bootstrap libraries from their CDN's in my project. I have enabled auto discover for outsourced files and it is working really efficent. My problem begins here. When i write code in "header.php", all bootstrap classes are loading very quick this is awesome. But when i start to work for example on "index.php" which includes "header.php", bootstrap classes are not loading for auto completion. I see all included files and so bootstrap.css on the top bar but Bootstrap CSS classes are not loading. This also happens in jQuery too. How can i make the code completion work for all php files which include a php file that has imported files from any CDN? I want the code completion work on all linked files and it does not matter how much system resources that it consumes!

I hope i could explain my problem. Sorry for my weak English.

Best Regards,

Caner

Views

236

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 28, 2019 Mar 28, 2019

Copy link to clipboard

Copied

Do you have a local testing server to parse your PHP includes?

I use Wamp server.    See screenshots.

CC-testingServer1.jpg

CC-testingServer2.jpg

CC-testingServer3.jpg

CC-testingServer4.jpg

CC-testingServer-final.jpg

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Thank you for your answer Nancy.

Yes, i have set up a local test server and a remote server over FTP. I am using WampServer too. Everything is okay when i run the page on design view's live mode. I know everything is working fine but i could not make the automatic code completion work. Here are the screenshot that you might desired to see.

Test Server

Ekran Alıntısı 2.png

Test Server Settings

Ekran Alıntısı 3.png

Ekran Alıntısı 4.png

Here is the code group that auto code completion works. You can also see bootstrap.min.css is included.

Ekran Alıntısı 5.png

Here the code completion is not working anywhere else

Ekran Alıntısı 6.png

Ekran Alıntısı 7.png

Do you advice any solution about this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

I have a similar set-up.  My <head> tag is populated from a PHP include that contains my CSS file.  I have no trouble with code hints in my parent document.  So I'm guessing you have some code errors that DW cannot reconcile.

  1. Open parent document.
  2. Go to View > Live Code.
  3. Go to Window > Results > Validation.
  4. In the Validation panel, click the triangle and select  Live Document.
  5. Fix reported code errors.
Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Thank you for your help Nancy but it did not work My page's status is "No errors or warnings to show." but auto completion still not working. I also closed and re-opened the Dreamveawer after code correction, but it did not work too Actually this situation is very insteresting because it does not even complete the class names which mentioned in the document too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

OK, good. No code errors.

Try Restore Preferences.

Unusual behavior in Dreamweaver? Try restoring preferences.

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

I complated reseting the preferences by Win+Ctrl+Shift+Double Click. It opened like brand new installation but unfortunately the same problem continues I am thinking that some buffering or pre-loading option should be checked at some preferences. Because code hints are working in header.php without any problem. I tried Dreamweaver CS5 before but there was not a problem like this. It was woking smooth.

I have checked the CSS Designer Panel and here is the status.

durum.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

Is Wamp server running?  Wamp icon should be green in your Windows Taskbar.

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

Yes it is working and all green.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

I am baffled because I have the same set-up on DW 19.0.1, Wamp server, Windows 10.  My CSS is referenced inside a PHP include file.  And the code hints & CSS classes all carry across to the parent document as expected.   I don't know what more to suggest.  

Maybe Preran  can ask the team if there is a setting I don't know about.

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 01, 2019 Apr 01, 2019

Copy link to clipboard

Copied

LATEST

Thank you, Nancy.

Caner SAYGIN : Please send me your Adobe ID, location, and phone number over a private message. To send a private message, click my picture and use the Message button. We will get in touch with you for further investigation.

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines