Highlighted

How to exclude/ignore specific errors in Dreamweaver output panel?

Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

Hi!

I have a problem which looks like this:

2017-10-24_11-56-06.png

50+ errors found in JavaScript.

But these are actually not errors, because I'm defining the TweenMax class in the other .js file before loading the current script.

The question #1 is: how to get Dreamweaver know that I'm actually defining the variable?

If it is not possible, then question #2: how to exlude, set to ignore or hide these specific errors from the panel?

I'm using Dreamweaver v18.0

Thanks in advance!

Adobe Community Professional
Correct answer by B i r n o u | Adobe Community Professional

I've posted a FR long time ago proposing that DW should adopt the same Site > Site options > Conseil de code specifique au site used for PHP, but including Javascript

have you try to set undef to false in the js lint options (preferences > linting > JS)

Views

947

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to exclude/ignore specific errors in Dreamweaver output panel?

Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

Hi!

I have a problem which looks like this:

2017-10-24_11-56-06.png

50+ errors found in JavaScript.

But these are actually not errors, because I'm defining the TweenMax class in the other .js file before loading the current script.

The question #1 is: how to get Dreamweaver know that I'm actually defining the variable?

If it is not possible, then question #2: how to exlude, set to ignore or hide these specific errors from the panel?

I'm using Dreamweaver v18.0

Thanks in advance!

Adobe Community Professional
Correct answer by B i r n o u | Adobe Community Professional

I've posted a FR long time ago proposing that DW should adopt the same Site > Site options > Conseil de code specifique au site used for PHP, but including Javascript

have you try to set undef to false in the js lint options (preferences > linting > JS)

Views

948

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 24, 2017 0
Adobe Community Professional ,
Oct 24, 2017

Copy link to clipboard

Copied

I've posted a FR long time ago proposing that DW should adopt the same Site > Site options > Conseil de code specifique au site used for PHP, but including Javascript

have you try to set undef to false in the js lint options (preferences > linting > JS)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 1
Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

I've just tried it. The errors disappeared. But this is not quite a solution. Because, as I underdtstood, now DW will ignore all the 'not defined' errors. And this is not right — sometimes I need to know that something is not defined. I want Dreamweaver to understand that the value of a specific variable is not a mistake.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0
Adobe Community Professional ,
Oct 24, 2017

Copy link to clipboard

Copied

I completly agree, lint should as eslint understand the statement

/* global var_foo */

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0
Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

Is it a solution? Sorry, I'm not familiar with Lint.

I've noticed something you mentioned, but what should I do with it?

Dreamweaver_2017-10-24_17-26-18.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0
Explorer ,
Oct 24, 2017

Copy link to clipboard

Copied

I guess I've found a right direction, but this doesn't work for me:

Dreamweaver_2017-10-24_17-47-40.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0
Adobe Community Professional ,
Oct 24, 2017

Copy link to clipboard

Copied

Ignore or disable code Linting on JS documents.   Use your browser instead.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 1
Explorer ,
Nov 11, 2017

Copy link to clipboard

Copied

For me, having this kind of side notes in DW is very useful.

Dreamweaver_2017-11-11_12-06-57.png

I want to continue watching them. So this is not a solution. The question was specifically about DreamWeaver, but not just about any workaround.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2017 0
artibaj LATEST
New Here ,
Mar 09, 2019

Copy link to clipboard

Copied

In file "JS.jshintrc.htm" add

"predef": ["TweenMax"]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2019 0