• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

The ZXP plugin cannot be published on the new distribut website

Explorer ,
Jun 28, 2023 Jun 28, 2023

Copy link to clipboard

Copied

I have a ZXP plugin that has been maintained for 2 years and has released many versions before without problems. Recently updated a version, on the new publishing site (https://developer.adobe.com/distribute/) to submit, the result could not upload the file, as shown below.

cantoserver1cantocom_0-1687952024125.png

 

The package failed scanning due to containing a 0 byte file. 

 

 

Have you encountered such a problem and how to solve it? thanks a lot!



Bug Unresolved
TOPICS
CEP

Views

265

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
8 Comments
Adobe Employee ,
Jun 28, 2023 Jun 28, 2023

Copy link to clipboard

Copied

Did you already reach out to ccintrev@adobe.com about this one?

 

The portal just migrated last week, so there are still some bumps in the road. Is your old ZXP in the Exchange? Can you send a link to it?

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 28, 2023 Jun 28, 2023

Copy link to clipboard

Copied

 

Yes, Emails have been sent, including our ZXP package, including error screenshots, But it's been two days and no reply yet.

This is the plugin we publish to the store:

https://exchange.adobe.com/apps/cc/103079/canto-connector-for-adobe

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 29, 2023 Jun 29, 2023

Copy link to clipboard

Copied

The Review team has been busy since the migration with support requests, however, it did appear that they never got your initial email. Based on a  behind-the-scenes Slack conversation, I believe your issue is moving forward. Thanks for your patience!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 06, 2023 Jul 06, 2023

Copy link to clipboard

Copied

Hi Gerard,

 

The team has identified the root cause of the problem you're experiencing The initial error [0 byte size files] was observed due to presence of sixteen "0 byte" file. To resolve this issue, please delete these files and upload the package once again.

 

We would like to inform you that the engineering team will be implementing some changes in the production environment on July 10th. Therefore, we strongly advise you to remove the "0 byte" files, repackage the zxp, and attempt to submit the patch on July 11th.

Votes

Translate

Translate

Report

Report
Explorer ,
Jul 07, 2023 Jul 07, 2023

Copy link to clipboard

Copied

Hi, I have the same issue and just to let you know that when I have deleted all the 0 byte file and uploaded the zxp again it told me tht there's an error and please try again later. I have also sent email to ccintrev@adobe.com with my zxp few days ago but I did not receive any reply. I hope the 10th July fix will also take my issus into consideration as well.Screenshot 2023-07-07 at 4.57.28 PM.png

Votes

Translate

Translate

Report

Report
Explorer ,
Jul 11, 2023 Jul 11, 2023

Copy link to clipboard

Copied

I've tried to upload the zxp today but the same error appeared: Error scaning xxx.zxp. Please try again later. Any idea on how to debug/fix this?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 25, 2023 Jul 25, 2023

Copy link to clipboard

Copied

Did get any solution of this issue

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

LATEST

The problem is that inside the extension there are files that have a size of 0 byte. On macOS you can search for them with this command:
find "dir_name" -size 0

After locating them, all you have to do is delete them and repackage the zxp.

In my case I had 2 files inside the node_modules library directory, doing the above procedure, I solved the problem.

Votes

Translate

Translate

Report

Report