Locked

mms.cfg settings not applying when whitelisting webcam URL using AVHardwareEnabledDomain

New Here ,
Sep 21, 2017 Sep 21, 2017

Copy link to clipboard

Copied

My company is implementing web conferencing software, which when using IE11 utilises the Flash add-in.  When a user opens the webpage, the flash add-in loads and prompts the user to allow or deny the webcam and microphone.

We would like to explicitly allow the camera and microphone for this URL for all users,  yet when defining this in the mms.cfg file the applet does not appear to respect the settings provided?

Yet, when I manually add the settings via the control panel  (Start Menu => Control Panel => All Control Panel Items => Flash Player the setting apply correctly and the webcam is automatically loaded when opening the page.

I checked the Flash Player Administrator Guide. Which defines the option for AVHardwareEnabledDomain. I enabled the option to the mms.cfg in both locations, %windir%\SysWOW64\Macromed\Flash and %windir%\System32\Macromed\Flash.

The contents of the mms.cfg contents, saved in UTF-8 with BOM follow:

SilentAutoUpdateEnable=0

AutoUpdateDisable=1

AVHardwareDisable=0

AVHardwareEnabledDomain=conference.example.com

Yet, for some reason the mms.cfg file settings are not applying, what have I done wrong?

Note, using ProcessMonitor I have been able to establish when adding the site in control panel 'Camera and Microphone settings by site' I can see a folder is created:

%appdata%\Roaming\Macromedia\Flash Player\macromedia.com\support\flashplayer\sys\#conference.example.com

Whilst it may be possible to deploy this folder file it seems a clunky way to resolve this issue, especially given the mms.cfg file should resolve this issue.

Thus far I've tested on a few machines, including;

  • Windows 10 64bit & IE11 (integrated Flash)
  • Windows 7 64bit & IE11 (Flash 23)

Views

618

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 06, 2017 Oct 06, 2017

Copy link to clipboard

Copied

LATEST

Hopefully you've figured this out by now, but I wanted to give you a response.  Sorry that it took so long.

Looking at pp. 28 of the System Administrator's Guide:

http://www.adobe.com/content/dam/acom/en/devnet/flashplayer/articles/flash_player_admin_guide/pdf/fl...

It looks like you need to have AVHardwareDisable set to 1, not 0, in order to disable the A/V hardware across the board to begin with, so I'm confused about why you're getting prompted in the first place.

Is it possible that you're putting mms.cfg in the wrong place (e.g. system32 vs sysWOW64), such that you're editing a different copy of the mms.cfg than you're running?  I'm just not coming up with a lot of reasons for why this would happen.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines