Ctrl+ combos have stopped working

Community Beginner ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

My IT folks reinstalled FM, and now the Ctrl+ combos don't work. Is this a configuration problem? We've reinstalled before without issue.

Views

192

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2018 Sep 17, 2018

Copy link to clipboard

Copied

Hi Raymond:

Did you get this resolved yet?

If not, can you clarify the question? For example, Ctrl+S won't save the file, and Ctrl+Z doesn't undo the last command? It sounds like you are an experienced user, but it may be worth mentioning for others reading this later that shortcuts don't work if you have a pod active, and not the document window. For example, if your cursor is active in the Paragraph Designer and then you tap Ctrl+S to save, nothing happens.

Also, what version of FrameMaker? What operating system?

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 17, 2018 Sep 17, 2018

Copy link to clipboard

Copied

Thanks for following up, Barb. Your question is on target. Those combos still work. It’s the ‘smart catalog’ combos that don’t:

Ctrl-0 to Insert Variable

Ctrl-1 to Insert Element

Ctrl-2 to Wrap Element

Ctrl-3 to Change Element

Ctrl-4 to Apply Condition Tag

Ctrl-5 to Remove Condition Tag

Ctrl-7 to Edit Attribute

Ctrl-8 to Apply Character Format

Ctrl-9 to Apply Paragraph Format

Also, when I try to open the Cross Reference pod, it flashes briefly, then disappears. The main impediment to working is inserting elements, but I can work around that by inserting them through the menu. I don’t have a work around for the CR issue, so that’s debilitating. I’m guessing other things are not working, either; I just haven’t discovered them yet.

Per Lynne, Amitoj Singh offers this response and suggestion: “Very strange problem. Can you ask the user to try and uninstall once and install FM again without any updates and see if it is working.”

That’s a predictable response that we haven’t done yet. Luckily, our pending delivery isn’t urgent, so we have time to sort this. It is very concerning, though.

Thanks,

Tony

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2018 Sep 17, 2018

Copy link to clipboard

Copied

Hi Tony:

I'm not experiencing issues with those shortcuts or with the X-ref pod staying open, so I'm going to concur with Amitoj that the next step is to give the old uninstall/reinstall a try, when it's convenient for you.

Let us know if that takes care of it.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 17, 2018 Sep 17, 2018

Copy link to clipboard

Copied

How do you shut down your Windows? Are you using the "Hibernation" mode, maybe with a special script?

I have some blurry memories that one user using a custom shut down to hibernation script was experiencing the smart catalog shortcut problem after waking up from hibernation mode.

Also, is there maybe any "shortcut highjacking" tool like AutoHotkey that has these shortcuts defined?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 17, 2018 Sep 17, 2018

Copy link to clipboard

Copied

Nothing has changed in Windows, nor in any tool, except the Adobe reinstall. So, I don’t think that’s it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 18, 2018 Sep 18, 2018

Copy link to clipboard

Copied

LATEST

Hi Tony / Raymond,

I'm the one mentioned by Stefan Gentz. But my problem is different to yours: randomly after hibernation in FM (15 or older versions) any CTRL-xxx short cut does not work (e.g. CTRL+c, CTRL+s, CTRL+0). Restarting FM is then required - loosing the current set up of document windows.

Looking at your problem:

The CTRL-# shortcuts are all defined in wincmds.cfg files of their workspace. Hence please verify, whether the following files are in place:

$HOME\fminit\configui\Structured\AuthorView\wincmds.cfg

$HOME\fminit\configui\Structured\FormsView\wincmds.cfg

$HOME\fminit\configui\Structured\CodeView\wincmds.cfg

$HOME\fminit\configui\Structured\WYSIWYGView\wincmds.cfg

$HOME\fminit\configui\UnStructured\WYSIWYGView\wincmds.cfg

($HOME is the installation directory of your FM)

... and whether they contain (for example) these lines:

<Modify QuickVariables<KeySequence  ^ 0    > >
<Modify QuickConditionalIn<KeySequence  ^ 4    > >
<Modify QuickConditionalNotIn<KeySequence  ^ 5    > >
<Modify QuickConditionalUn<KeySequence  ^ 6    > >

If this is all OK, then try this:

  • You notice that CTRL+0 does not work
  • Switch to Workspace Blank (all pods will disappear)
  • Switch back to your used work space.

If the roblem persists; try this:

  • Rename your %appdata%\Adobe\FrameMaker\vv to … \vv-saved
  • Restart FM

vv is your FM-version, e.g. 15

If the problem persists: "I'm at the end of my latin"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines