DITA-OT output failed

Advisor ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

At first glance, this gives me the impression something needs to be udpated … but I'd welcome clear advice on what to update and how. FM 15.0.6.956, Windows 7.0 on corporate life support. Thanks in advance.

BUILD FAILED
C:\Program Files\Adobe\Adobe FrameMaker 2019\fminit\ditafm\DITA-OT\build.xml:49: The following error occurred while executing this line:
C:\Program Files\Adobe\Adobe FrameMaker 2019\fminit\ditafm\DITA-OT\plugins\org.dita.base\build_init.xml:99: java.lang.UnsupportedClassVersionError: org/dita/dost/invoker/ExtensibleAntInvoker : Unsupported major.minor version 51.0

 

TOPICS
Error

Views

212

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 12, 2020 Aug 12, 2020
Hi, The java.lang.UnsupportedClassVersionError error message with an Unsupported major.minor version usually occurs when the system doesn't meet the minimum Java requirements. Can you please confirm the Java version installed on your machine? Here is the link from where you can download the Oracle JRE or JDK-  https://www.oracle.com/java/technologies/javase-downloads.html Regards, Ajit

Likes

Translate

Translate
Adobe Employee ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

Hi,

The java.lang.UnsupportedClassVersionError error message with an Unsupported major.minor version usually occurs when the system doesn't meet the minimum Java requirements.

Can you please confirm the Java version installed on your machine? Here is the link from where you can download the Oracle JRE or JDK-  https://www.oracle.com/java/technologies/javase-downloads.html

Regards,
Ajit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 19, 2020 Aug 19, 2020

Copy link to clipboard

Copied

LATEST

JRE 8 installed, error message gone! thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

Thanks for the quick response: I see my corporate laptop is running java 1.6.0_65. Could you tell me where to find the requirements? corporate paranoia means I'll have to ask Support to carry out any update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Hi,

I believe you can install JRE 8 using the link that I have shared earlier and it should work fine.

Here is the link for FM 2019 system requirements- 

https://helpx.adobe.com/in/framemaker/help/fm_system_requirements.html

 

Regards,

Ajit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Thanks for the extra information – duly passed on to our in-house Support, who tell me they're putting the JRE 8 installer somewhere I can run it. Fingers crossed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines