drawing does not update when editing within anchored frame

Community Beginner ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

i newly started using framemaker 2020 on windows after working with an old framemaker version on solaris so far.

i'm actually drawing my first picture in an anchored frame of an fm2020 document which starts as a nightmare:

whenever adding or moving a line, or copying a group of lines or text, this is either not shown at all after drawing or  pasting, or shown in a wrong position, or complete nonsense is shown. so i always need to change zoom level to see the actual drawing, i.e. to update the display.

i don't think that this is expected to be like that. is there a bug in the actual version of fm2020 or do i need to add or change some configuration?

see examples attached.

Views

158

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Are you all patched up in your copy of FM2020? I can't offer you much advice about the drawing tools in FM because I've never used them (always done stuff like that outside FM and imported by reference).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

it at least says current version 16.0.4

is there another place to get support?

having the internal graphics editor is one of the main reasons for me to use framemaker.

i would assume that this should work at least as fine as it does in the old fm5.5 i used before.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

quotehaving the internal graphics editor is one of the main reasons for me to use framemaker.


Really? Never thought graphics was a FM strength - you might try the FM folks (see https://helpx.adobe.com/contact/enterprise-support.other.html#framemaker for your Adobe Support options. I'd recommend using the tcssup@adobe.com e-mail address as it reaches a team dedicated to Technical Communication Suite products including FrameMaker.) if nobody else chimes in - stilll a bit early for the US west coast to be seeing this.
IIRC @Shlomo Perets used to have a talk out there on the use of the FM graphics features.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Hi,

 

Do you have Snap activated in the View Options in the View Menü?

This could cause your symptoms.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

i do not see a "snap" option there

view_options.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

frame2020-graphics-snap-turned-on.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

ok, found it, thanx!

snap was enabled, so i disabled it to start a new drawing. besides, that it now was hard to draw a straight line, it suddenly worked fine. then i reenabled snap, and it was still fine for some time. after drawing a few more lines and doing some more edits, the problem started again. disabling snap did not help at all now. 

so it looks like once the issue starts, it persists ;-(

is this anything known? is there a fix?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

I'm afraid that, like Winfried, I don't use the FrameMaker graphics tools. Our graphics have to be available for multiple documents, so they are created in Visio and imported by reference.

 

ETA: You might try a MIF wash to see if that helps. Or create a new document and copy/paste everything but the graphics and start redrawing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Whether an object snaps to the virtual grid or not is defined by a button of the Object Properties tool bar. There is another button/switch called gravity. This lets you attach a new object to an existing one by "magnetic" force. 

I use the FM graphic tools very often - not only for call outs. See for example https://www.daube.ch/docu/files/compendium.pdf page 214 ff.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

martin23187238cfh0: … whenever adding or moving a line, or copying a group of lines or text, this is either not shown at all after drawing or  pasting, or shown in a wrong position, or complete nonsense is shown.

What happens when you do a [Ctrl]+[l] (lowercase L) to refresh the view? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

thanx for the compendium. looks really helpful!

 

[Ctrl]+[l] really helps to update the drawing. but it does not seem really helpful if it's required to press [Ctrl]+[l] after each action done...

 

what i found out:
as soon as a group of drawing objects i move contains text which has been rotated 90° (it's even enough to just move or copy a single word which has been rotated 90° before), then the problem occures.

i.e. when i write a word, rotate it 90°, select it and do a copy paste, the pasted word does not show up until i do a [Ctrl]+[l]. 

when i write a word, rotate it 90°, move the word, it either does not show up or shows up at a wrong position or shows up twice. then [Ctrl]+[l] is required too.

as long as i do not have any rotated text, it seems to work...at least in the test i did right before.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2022 Feb 17, 2022

Copy link to clipboard

Copied

If refreshing irks you, fire off a bug in the Tracker (https://tracker.adobe.com/) to get it on FM's radar.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2022 Feb 17, 2022

Copy link to clipboard

Copied

Jeff, I wish all the reports in the bug base more attention...

The lack of automatic refresing the screen after most operations is so old as FM - and tabling it the beta-forums since years does not show any solution...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2022 Feb 17, 2022

Copy link to clipboard

Copied

K.Daube: The lack of automatic refresing the screen after most operations is so old as FM…

There's likely some history there. We might think that doing a refresh after every action would be obvious, but…
When I started with FM 3.x, probably on Windows 3.1, a page with an 8×10in 300dpi color TIFF image would, no exaggeration, take a half hour to refresh. I quickly learned about the advantages of EPS and its thumbnails.

In order for FM to decide for itself to do an auto-refresh, it probably needs to be able to estimate how long that will take (sizes & complexity of visual page content, available RAM, graphics speed, locality of objects, etc.) That likely isn't something that could be computed back in the day, and it may not be a slam-dunk today (esp. in some networking scenarios, and/or if FM ever has a cloud-app option).

Nonetheless, the minimum system requirements for FM have evolved, and it might be time to re-visit the code, and tweak the refresh. Perhaps there could be a not-too-hidden config preference item.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2022 Feb 21, 2022

Copy link to clipboard

Copied

LATEST

while working with fm5.5 (on solaris) so far, i never had such issues.

therefore it's clear: adobe could do it better!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines