• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Fix Table Auto-Numbering

Community Beginner ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

I'm working on a user guide where some chapters are split across multiple files. Because of that, I need figures and tables to auto-number so any future additions won't affect the numbering across every file. However, when I am adding table information to one of the files, the auto-numbering bugs out to where it goes from table "1" (the first table for the section, but 19 overall for the chapter) to "5", and the auto-numbering won't allow me to correct the sequencing. I even tried adding the tables all at once and add the information after that. The numbering is correct when I first add all the tables, but then the numbering changed as I added information to the first table. I then thought that the first table being across multiple pages is messing with the numbering, but it's only been one section where this is happening to me while everything else has been working correctly. Am I missing something?

Views

237

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jan 27, 2024 Jan 27, 2024

Hi Chris:

 

I see you are new here—welcome!

 

Were the earlier replies able to help you figure this out? If so, please come back to mark whichever one solved this issue for you as correct. If not, can you let us know and we can continue to try to help you.

 

Since you are new here, we don't know how well you know FrameMaker yet. Is this your first time setting up auto-numbering? Are you familiar with the concept that FrameMaker increments numbers across a file (and eventually a book) without reg

...

Votes

Translate

Translate
Community Beginner , Jan 30, 2024 Jan 30, 2024

Thanks for the hints. I finally figured out that the tables had numbering sequences in the cells that had the same series indicator as the tables. It was the only section with them, which was why the other auto-numbering didn't have any problems. After using a different indicator, the numbering went back to normal. Thanks a lot.

Votes

Translate

Translate
Community Expert ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

what app are you using?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

It's FrameMaker.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

@Chris257053384nun 

 

I've moved your post from Creative Cloud Desktop to the Adobe InDesign forum for you.

 

Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

Sorry I didn't specify, but the topic was about FrameMaker.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

@Chris257053384nun 

I've moved your post to FrameMaker where the Experts here can assist.

Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

It sounds like the paragraph style you're using for the table title conflicts with other numbering within your document.

First, are you numbering the paragraph containing the table anchor, or are you specifying the table title (recommended) in the Table Tag via the Table Designer? Using the actual table title is important so that numbering, sheet, and continuation variables can make multipage tables easier to understand.

Then, check the numbering properties of your table title paragraph style. This will give you clues as to why the numbering is getting wonky. Since your table numbers jump from 1 to 5, you will likely find three paragraphs of a certain style (numbered 2, 3, and 4) inadvertently increasing the number associated with your tables. 

 

Solutions:

  1. To pick up the previous file's numbering for the table title, go to Format > Document > Numbering and set the Paragraph Numbering to Continue from Previous
  2. Either
    • add another building block to your table title paragraph numbering style (something like <n+> in the appropriate position)
    • add a series indicator (something like T: or Q:, as long as it's a single character followed by a 🙂 to isolate your table title from other paragraph style numbering

Hopefully you already created a book file so that the numbers can continue as specified.

For more info on numbering paragraphs and tables, see my reference book, FrameMaker - Working with Content

-Matt

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

The book was set to reset the numbering because I wasn't sure whether or not the numbering might be affected if, for example, numbering continues for tables when the previous section doesn't have a table in it. Otherwise, the auto-numbering format is set up as:

 

T:Table <$chapnum>-<n+>.

 

My issue is that only one section is acting up like this. Every other section, when the numbering was set to reset or continue, the sequencing was fine. I'm just not sure what would affect one section while leaving everything else alone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

Hi Chris:

 

If you are comfortable sharing that file, I'm happy to take a quick look. You can put it on a shared drive like dropbox and post a link here, which is public or you can click my avatar and message me directly, which is private.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

If the jump in numbering is within the same file, display the Paragraph Designer and then use your down arrow to look at the settings for every paragraph between the jump in table numbers. 

You will likely find a paragraph with numbering properties that are inadvertently resetting the T: series you are using for your table titles.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

re: I then thought that the first table being across multiple pages is messing with the numbering…

That could happen if the additional pages of what is supposed to be the same table, are in fact new tables, rather than taking adavantage of letting FM do it's own Table continuations.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2024 Jan 27, 2024

Copy link to clipboard

Copied

Hi Chris:

 

I see you are new here—welcome!

 

Were the earlier replies able to help you figure this out? If so, please come back to mark whichever one solved this issue for you as correct. If not, can you let us know and we can continue to try to help you.

 

Since you are new here, we don't know how well you know FrameMaker yet. Is this your first time setting up auto-numbering? Are you familiar with the concept that FrameMaker increments numbers across a file (and eventually a book) without regard to the paragraph style? That means if you have a table with a number, followed by a figure with a number, followed by another table witha number, FrameMaker will increment the numbers as Table 1, Figure 2, Table 3. The key to sorting this out is to assign a Series Label (as per Matt) to let FrameMaker know that these are separate numbering series. And like Matt, I suspect that you have four incremental counters in front of the table that don't have their own series label, which is forcing Table 1 to display Table 5. Maybe a list of steps? Or numbered heads?

 

We can share additional thoughts and resources if you still need help. Just let us know.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

Thanks for the hints. I finally figured out that the tables had numbering sequences in the cells that had the same series indicator as the tables. It was the only section with them, which was why the other auto-numbering didn't have any problems. After using a different indicator, the numbering went back to normal. Thanks a lot.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

LATEST

So glad you are back on track, @Chris257053384nun. We'll see you next time you run into difficulty. We are always happy to help.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines