• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

FM 2015 sometimes does not allow me to insert a space between words

Contributor ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

Hi,

I am using FM 2015.

The following has happened to me many times. I have not found a pattern as to why or when. Has anyone else seen something like this?

The case is like this. I have text and I want to insert a space and a new word.

For example, today I had the following text:

"Each checker actual output argument shall be variable_lvalue or net_lvalue."

I want it to read

"Each checker actual output argument shall be a variable_lvalue or an net_lvalue."

adding " a" after "be" and " an" after "or".

However, when I typed the additional text, with the space before them, I got the following:

"Each checker actual output argument shall bea variable_lvalue oran net_lvalue."

Track edits is on.

What I actually see are the inserted spaces, but they are crossed-out red, i.e., deleted by FM.

I work around this by forcing spaces, using CTRL + space, but I should not have to do this.

Any ideas?

I have already asked Barb Binder privately, but she said she never said or heard of this.

Thanks!

Shalom

Views

211

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Sep 19, 2022 Sep 19, 2022

OK.

I admit it.

I was wrong, at least in the particular example I reported.

I was correct that it was not connected to Conditonal Text.

But I was wrong about the rest, at least partly.

It turned out in this particular example that Track Edits was On (which I knew and want and need) and Smart Spaces was also On (which I did not know, as it is Off in most of my files).

Weirdly, it seems that the problem occurs only when both are On.

I would not expect that it would be connected to Track Edits.

In retrospe

...

Likes

Translate

Translate
Community Expert ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

I'm following this, @shalomb61686619! 🙂

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

Hi Shalom, do you use either conditional text or the Track Text Edits in FrameMaker?

Do you import PDF comments/changes back into your Fm docs?

 

If so, check your conditional text settings to make sure nothing is being hidden.

To me, it sounds like you may somehow be entering characters that might be conditional, and hidden.

Another thing to check would be your Track Text Edit toolbar settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

Hi, Matt.

 

Conditional text setting is to show all.

Track Edits is ON.

As I wrote, it is not like in Smart Spaces, where if I type extra spaces, they do not show up at all. Here, it shows that I typed a space and it was automatically deleted. It shows up with a red crossout. On the other hand, if I type CTRL+space instead of just 'space', forcing the space, then it is OK.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

A bit of a guess, but try saving a copy of the document, then select all and press control six. Also, try turning off tracked TextEdit. Pardon any typos or grammar, I am on my phone right now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

What does ALT CTRL 6 do ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

I'll see whether I can make a simple test case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

Control six removes any conditional text tags applied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Hi,

 

Yes. The red crossout is correct. That's what I experience as well.

When I have Track Changes enabled, and I put the insertion mark before a space without any Track Changes conditions (i.e. the space is not green) and enter a space, then the existing space will be deleted.

The reason is:

There is an existing space. You have Smart Spaces activated (Format | Document | Text Options).

When you add another space, then the existing space will be deleted (crossed out, marked in red via Track Changes) and another space entered.

However, as there is already a space, no space will be entered.

 

At least this is my interpretation.

This is very similar to text with a condition.

When you enter a space before an existing space, then the new space will not have a condition.

 

This is clearly a bug! I recommend to enter this issue in the Adobe Tracker:

tracker.adobe.com/

 

When you post the issue number of the Adobe Tracker here, I will definitely vote for it!

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Hi,

 

OK. I had not checked the Adobe Tracker database thoroughly.

There is already a description:

https://tracker.adobe.com/#/view/FRMAKER-8467

I think this is something which should be fixed! Therefore I recommend to vote for it!

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Winfried's case is not mine.

In my case, there is no existing space and Smart Spaces is OFF.

Also, conditional text is set to Show All.

I looked at the bug description Winfried pointed to.

That description implies that this always happens.

But in my case, it happens sometimes, but not most of the time.

As I wrote previously, I have not yet discovered the pattern determining when it occurs and when not.

And for clarification, when it does occur, it is repeatable. 

That is, I cannot tell in advance where it will occur, but when it does occur in a particular place, it happens always.

The bug description suggested using Reject Change to remove the deletion.

I had not thought of that and will try it the next time it occurs to me.

For good order, I will do what Matt suggested, though I am pretty sure it will not change anything.

But I have to prove that 100%.

I also have no idea whether this still occurs in newer versions, though the bug report suggests it does.

 

Shalom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

For clarity, I wasn't trying to "fix" your problem, as much as diagnose it.

I suspect your Track Text settings are at the base of it, and from the above descriptions, it might be that a "replaced" space is displaying differently than a "new" space.

Frustrating, but not much different than the display of rulers, text symbols, etc. being considered a "document change" for purposes of saving a document.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

But this is not a display problem.

I am trying to insert a space where none exists.

Even, as in my example, I now have the text "oran" because it ignored the space I typed, if I go back and try again to insert it, FM won't let me. It keeps on deleting the space.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

What happens if you temporarily turn Track Edits off? Can you insert the space or not?

 

Toggling that on and off is probably going to be a PITA, but it might work.

 

Meantime, I suggest getting in touch with the FrameMaker technical support team. You can email them at: tcssup@adobe.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

As I wrote, my current workaround, which is easy, is to insert CTRL+space, which forces a space.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Fair enough, but if you could test what happens with Track Edits off, we might be able to eliminate it as a possible cause.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Fair enough.

Maybe I can get to it tomorrow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

OK.

I admit it.

I was wrong, at least in the particular example I reported.

I was correct that it was not connected to Conditonal Text.

But I was wrong about the rest, at least partly.

It turned out in this particular example that Track Edits was On (which I knew and want and need) and Smart Spaces was also On (which I did not know, as it is Off in most of my files).

Weirdly, it seems that the problem occurs only when both are On.

I would not expect that it would be connected to Track Edits.

In retrospect, I understand why Smart Spaces would affect this.

Normally, one thinks of Smart Spaces as removing extra spaces after an existing space.

In this space, I was adding a space before an existing space.

But oddly, if Track Edits is Off, it still lets me do this.

Since I want to add new words into existing text, I can just add the extra space I need after the last new word instead of before the first new word.

Thanks for everyone's help and I apologize for wasting your time.

I will report if I encounter a case that is different from this one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

No waste of time. Very good that you found the cause! Have a good day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

LATEST

Glad you worked it out. Sometimes all it takes is banging your head off other people's ideas to figure out what is going on. 😄

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Hi,

 

Could it be that your issue is related to your font? What do you use? What happens when you switch to another font, e.g. Arial?

 

Best

Winfried

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines