Font Issue

Explorer ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Greetings, 

My coworker is having font issues with Frame 2019/Windows 10. I've copied all of my fonts to a folder for her and she installed them, but she's still getting a range of font issues. This is a legacy document that has had many font replacements over the almost two decades.  In the attached image, you'll see that questions marks are substituted for apostrophes, bullets and quotes (among other things). Any help is deeply appreciated! 

2020-10-13_9-53-53.png

 

Views

136

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

I stuck your image into your message - much easier to see that way.
Are you getting any missing font messages?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Thanks! It is much easier. And yes, there are missing font errors, even though she has the same font directory as I do, only she gets the error and it opens clean on my end.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Hi,

Question marks are usually substituted when the correct language or font isn't selected/found.
What exactly are the errors you are getting? If this is related to some fonts not found.
Please verify if a particular font is installed or not (C:\Windows\Fonts).
After installing the desired fonts, Restart FM.





Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Thank you. It appears that she has the correct fonts installed, but is still getting missing font errors.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

re: Question marks are usually substituted when the correct language or font isn't selected/found.

Another possible explanation is that the font on the receiving system doesn't populate the code points used in every instance. The document might be using, for the ? instances:
U+2022 BULLET (\u2022, instead of FM's internal \b)
U+2019 RIGHT SINGLE QUOTATION MARK (\u2019, instead of FM's internal \xd5)
In this scenario, although the receiving system has a font of the same name, it's a legacy (non-Unicode) font populating no code points above U+00FF. This, however, might be contradicted by some of the bullets appearing, and some not.

 

Is this a "variable font"? FM doesn't support those yet, and we see peculiar problems being reported when used.

 

? can (and will) also appear for any Unicode character in SMP (code points higher than U+FFFF), as FM doesn't support SMP yet. This would be expected for most emoji, for example, but isn't likely the explanation here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Stupid questions time, but:

  • Have you tried a MIF wash? Or have you tried viewing a MIF version of the file in a text editor to see if there are odd tags or font changes at the non-displaying glyphs?
  • Are her paragraph and character tags up to date? 
  • Is the language set to English on the Font tab for all her tags?
  • Is Asian composer turned on? Try turning it off if it is.
  • Is "Remember Missing Font Names" turned on in Preferences? If so, try turning it off and seeing what happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 14, 2020 Oct 14, 2020

Copy link to clipboard

Copied

LATEST

Hi,

 

Can your colleague check the first font which is reported as missing?

Do you get also a message, when you deinstall this font?

Can you and she search your hard drives for this font? Possibly there is an additional folder with this font.

Can she apply the font? Which characters are displayed as question marks? Can you paste them here?

MIF wash as Lin suggested is definitely a good idea.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines