handling long URL

Explorer ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

I'm trying to add a long URL to a bibliography entry. I'd like Frame to just accept what I type without adding hyphenation, space between words, etc. I've tried every option I can think of, em -spaces, etc. No luck.

Views

77

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 30, 2022 May 30, 2022
So removing the forward slash from the list of characters seems to be the only option. Frame really needs a non-breaking forward slash.

Likes

Translate

Translate
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

What happens if you just paste it in from something like Notepad?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

No change, but it does seem that it's the forward slash that triggers a new line

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

So removing the forward slash from the list of characters seems to be the only option. Frame really needs a non-breaking forward slash.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

I  have the following constellation for a working Hypertext command. The text source braks at the / as defined in the Text Options.Long-URL.png

To present a long URL in the text, you need to have some breaking of it. At a first solutio I would define a character format for the link which has no Language assigned and thus does not hyphenate (I use the format computer for this):

Long-URL2.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

LATEST

Frame really needs a non-breaking forward slash.

A forward slash is allowed to break because of the settings in Format > Document > Text Options. If you remove the forward slash from the Allow Line Breaks After list (seen above in @K.Daube's screen shot), it will not appear at the end of the line. (From left to right: forward slash, hyphen, en dash, em dash.) Note: this is handled on a document by document basis. You will need to import this setting into your other files with File > Import > Formats > Document Properties.

 

That said, I much prefer shortened links whenever possible. The layout is so much easier. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines