• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Highest level headings on odd-numbered pages

Explorer ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

FrameMaker forces heading level 1-chapters to start on pages with even numbers, and I don't know why or how to make them start on the next available page, even if it is an odd number.

I created my chapters by letting FrameMaker convert Word documents. I don't know if that has something to do with it, although the headings could start anywhere in Word. I would appreciate any help.

TOPICS
Formatting and numbering

Views

420

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 16, 2023 Nov 16, 2023

This happen because you need to select all the files in the book and then apply a pagination which lets FrameMaker pick the next available page. Like this:

StudioSm_0-1700124254481.png

 

Votes

Translate

Translate
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

I think it's in your Master Page formatting - you've told it to start like that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

Have you tried looking into the Pagination tab of the heading in Paragraph Designer? Might be a setting there.

StudioSm_0-1699972104910.png

 


Bjørn Smalbro - FrameMaker.dk

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

I am using the Start setting "Top of page" which should be independent of the page numbering, I think.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

Maybe it is a pagination setting

StudioSm_0-1699973263442.png

If you have a setting in the master page mapping table that would explain it:

https://help.adobe.com/en_US/framemaker/2019/using/using-framemaker-2019/user-guide/frm_page_layout_...


Bjørn Smalbro - FrameMaker.dk

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

A test file, created from one of the problematic .fm  files, worked. I didn't make any changes to the heading paragraph. It feels like FrameMaker is just as unpredictable as Word.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

Your suggestion seems to be right. I chose the setting "Delete empty pages", but Framemaker changes this to "Make page count even" and adds an empty page when I update the book. I have some chapters containing only one page (but FM has its own opinion about this).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

You have to set your pagination properties at the book component level, not the document level.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 16, 2023 Nov 16, 2023

Copy link to clipboard

Copied

I got rid of the empty pages in the one-page chapters. However, the problem remains in the multipage chapters. I apply the setting “Delete Empty Pages” to each one of the chapters. The empty pages are deleted and everything looks fine. I save the chapters. After an update of the book, FM adds empty pages and changes the setting back again to “Make Page Count Even”. Even if I change the setting to "Make Page Count Odd", FM changes the setting back to event count and adds empty pages after a book update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 16, 2023 Nov 16, 2023

Copy link to clipboard

Copied

This happen because you need to select all the files in the book and then apply a pagination which lets FrameMaker pick the next available page. Like this:

StudioSm_0-1700124254481.png

 


Bjørn Smalbro - FrameMaker.dk

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 16, 2023 Nov 16, 2023

Copy link to clipboard

Copied

LATEST

All empty pages are gone! I am very grateful for your help, thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

re: FrameMaker forces heading level 1-chapters to start on pages with even numbers…

It doesn't, unless being instructed to do so by Pagination properties, Master Page Mapping (probably not your case), or some more obscure issues (keeps, widows, orphans).

re: I created my chapters by letting FrameMaker convert Word documents.

Endless entertainment. Start by inspecting all the auto-created paragraph tags.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

"Endless entertainment." LOL. That's the understatement of the day!

 

~Barb 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

Hi Peter:

 

Can you clarify the words "heading Level-1 chapters"? Do you mean each chapter in the book window starts on even pages? Or are you referring top level heads within a single Fm file? 

 

If the latter, see @StudioSm's answer. Start "top of page" will force the paragraph to the top of the next available page: left or right. If that isn't working for you, please show us at least a two-page view with your cursor in your top level heading, text symbols visible, Paragraph Designer open and Pagination properties visible so that we can see your settings. 

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

Hi Barb,

In the picture, heading 7 Product overview is a level 1 heading, my highest level of heading.

There is a T-shaped non-printing character between “7” and “Product”. I don’t know what it means.

Regarding the two-page view, I should have mentioned that the problem shows up when I create PDF files. I did a test file in the FrameMaker book file, and the top-level headings started on both odd and even pages in FrameMaker and in the PDF. The rest of the chapters had the problem with the headings in the PDF. The test file is based on one of the chapters that has the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

There's a continuation. I created a new heading 1 style and replaced the old one. It works in some cases, but not in others. Frustrating.

Maybe I should try creating new .fm files for the chapters instead of just the paragraph style.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

Email me offlist. We can probably figure this out quickly via a web meeting. Thanks. rick at frameexpert dot com

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

Rick will help you straighten this out. 

 

In the meantime: "There is a T-shaped non-printing character between “7” and “Product”. I don’t know what it means."

2023-11-15_08-08-33.png

It's a marker: likely a cross-reference marker or maybe an index marker. Open Insert > Marker and then select the paragraph. The Marker panel will ID it for you. Since it doesn't relate to pagination, if you have additional questions about it, please start a new thread.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 16, 2023 Nov 16, 2023

Copy link to clipboard

Copied

OK, thank you for your time!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines