How to remove extra paragraph tag after a text inset in Framemaker 2019

Explorer ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

Hi all,

I have a text inset that needs to be placed after a heading and is the only content in the section. When I insert the inset, there is always an extra paragraph tag after the inset. When I click on the inset, this tag is included in the selection but the tag is not present in the inset .fm file.

 

Is there an updated solution to this problem for Framemaker 2019?

 

thanks,

Elo

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

A text inset has to be anchored in a paragraph in the container document. That is why you see an "extra" paragraph in the container. The best approach is to make a dedicated anchor paragraph format that is small and won't cause you formatting problems.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

@eloeso - Nope. Still happens, and it's a long-standing thing with FrameMaker. I found a post by Richard Combs on the frameusers mailing list back in 2011 that explains this.

 

Quote-----------------------------------------------------------------

 

No "extra blank paragraph" is created (and certainly not "sometimes" as if it were a random event) when you import a text inset. This belief stems from a fundamental failure to understand how FM handles text insets. The "extra blank paragraph" is the empty paragraph in which your cursor was sitting when you imported the text inset.

text inset is something like an anchored frame or table. It sits in the flow as a zero-width object at the spot where you inserted it, i.e., the "container" paragraph. You can demonstrate this to yourself by putting the cursor at the end of the paragraph before the text inset and then pressing the right arrow key repeatedly. You'll see that a single key-press moves the cursor from just before the text inset to just after. Type some text after the inset, then triple-click somewhere in that text to select the entire paragraph. You'll see that the text inset, like the rest of the paragraph that contains it, is selected.

Since the text inset source is a complete flow, it necessarily ends with a paragraph end. So the "extra" space is the result of two paragraph ends in a row: the end of the last paragraph in the text inset source and the end of the empty container paragraph into which you inserted it. The run-in paragraph solution that post outlines is one way to eliminate the "extra" space. Another is to not insert the text into an empty paragraph; instead, insert it at the beginning of the text that should immediately follow the text inset

 

Quote-----------------------------------------------------------------

 

NB: The "that post" he refers to was a solution posted to the freeframers list, which no longer exists and its archives are now gone. I do not know the contents of that post. He goes on to suggest inserting a non-breaking space between the inset container and the paragraph pilcrow, but that has never worked for me. The inset shows above the containing paragraph, always, so it appears you have an extra, empty paragraph.

 

Making a paragraph tag to hold the inset and setting it as a run-in paragraph works in that you won't have two blank lines in a row, but you will still have a blank paragraph. You said that there's no text after the inset, so unless this is pushing you over to a new page, I wouldn't worry about it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

Thanks for the explanation linsims. 

The problem for me is that there is an awkward empty space after all of my insets before the next heading - see the bottom of this example:

Inset-Gap.fm.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

You're putting the text inset into it's own paragraph, right? That's why you have the "blank paragraph" below the appearance of the text inset. That's the paragraph holding the text inset. By way of analogy to an anchored frame, for whatever reason, text insets are set to show "above paragraph" and there's no way to set their properties to "at insertion point".

 

I've yet to find a way to fix it, mostly because I don't work with text insets.

 

You can try inserting the text inset in the following heading paragraph, making sure it is at the very, very beginning of the paragraph (insert cursor in line, press HOME a couple of times). That makes the heading paragraph the container for the inset. I'm not sure how or if that will affect the formatting of the text inset or the heading paragraph, though. Text inset formatting can affect the formatting of the containing paragraph, but my understanding is that this happens only if there isn't something between where the inset is inserted and the pilcrow indicating the end of the paragraph and inserting it before the text in the heading should suffice for that.

 

I personally don't like that solution, but that's because, for the most part, I like things like tables and anchored frames to each have their own containing paragraph as it make it easier to select the anchor. Insets don't have anchors, but I'd probably extend the habit.

 

You could try playing with the font size of the containing paragraph and the space above or below. That's how I set up the Anchor tag for my tables so that the table is basically inline. (Anchor: font size = 2 point, space below = -2 points). For inset anchors, maybe font size 2 and space above -2?

 

Edited to add: Which is basically what Rick suggested. Listen to Rick. He knows. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

LATEST

Ok, I get it now (have only been using Frame for a couple of months). I tried putting the anchor point at the beginning of the next heading and that does work visually, but when you click on the TOC link for the following paragraph it links to the top of the inset instead of the heading.

 

I created the short anchor paragraph style and that helps a lot. Setting the space above (or below) to a negative number doesn't seem to change anything so am not sure what I'm doing wrong there.

 

But in any case this looks much better - thanks!

Elo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines