Hyperlinks in PDF TOC Do Not Work

New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

I am generating the PDF by setting up a PS file. The settings are all in place but the output PDF doesn't have the hyperlinks to topics in TOC in the PDF file.

Views

180

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Hi,

 

What's your FrameMaker version? You can also use Save as PDF to create your PDF file.

When you print to a PostScript file, make sure that the option Generate Acrobat Data in the print dialog is activated.

You can also test, if your TOC has hyperlinks, when you press the CTRL and ALT keys and keep them pressed and hover over the single lines in your TOC. When they change to a pointer, this is an active hyperlink and you can click. This should open the correct file and paragraph.

Check also, if hyperlinks are enabled. In the book file right click on the TOC and click Set Up Table of Contents. In the Setup dialog the option Create Hyperlinks must be activated. If not, activate it and update your book.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

The Framemaker version is 2019. Yes the Create Hypertext Links check box is selected and so os the Generate Acrobat Data in the Print dialog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

And when you press CTRL + ALT and hover over the paragaphs in your TOC? Do you get a pointer?

It could also be that the active hyperlink area was interrupted by a change in the character format. Only when the whole paragraph has the same character format, the hyperlink is active across the whole paragraph. Hover from the beginning of a paragraph to the end with the page number.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Yes, when I use CTRL+ALT the pointer change. Check the image below.Framemaker_TOC.png

 

hanges.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Apologies for the typos. My touchpad and alptop screen are behaving weird.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Which printer do you use? You should use Adobe PDF.

And even when you prefer to print to a PostScript file and distill it, can you Save As PDF as a test?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

The printer is Adobe PDF. I used the Save as PDF option as well. The links in the TOC are still not hyperlinks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

As you can see your paragraphs are active hyperlinks in FrameMaker.

Only when you create a PDF, these hyperlinks are not active. Hm.

Which PDF viewer do you use?

When you hover over these paragraphs in your PDF viewer, does the cursor change to a pointer?

In Acrobat you can check the area of your hyperlinks, but I forgot, where you can show the borders of your hyperlink areas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

I used Adobe Acrobat for PDF viewing. The cursor doesn't change to pointer in my PDF. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

I do not know, what else could cause this. Everything seems to be correct.

If you like, you can send me the PDF and the FM book with only a single file and the TOC as a private message. Then I will have a look.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

LATEST

There is one more thing that could be checked:
What is the exact text of the hypertext?
There is a bug that even crashes FrameMaker, which occurs when you have a space between the filename and the colon.

https://tracker.adobe.com/#/view/FRMAKER-9705

e.g. "gotolink document.fm :target" instead of  "gotolink document.fm:target"
Maybe this also has an effect when creating PDF.(This is only a guess)
Please check the exact spelling.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines