Highlighted

CodeBlock Breaks in FM HTML5 Output...

New Here ,
Nov 05, 2019

Copy link to clipboard

Copied

In FM 11 shift + enter at each line generated pretty codeblock in my html web page. Using HTML5 via FrameMaker 2017 (structured) > Publish +1k Topics > HTML 5 -  the pretty print on my codeblock element breaks, shows as one continuous line (image a). When I compile only one topic, the same topic, or a handful of topics (6 topics) that contain the codeblock element in a separate ditamap, the codeblock is well formed (image e). FrameMaker topics and user guide retains and shows the codeblock in pretty print (image f). I have one topic that contains several distinct chunks of code, oddly, one of the chunks is well formed (image c) but the other two break in the same topic. To quick fix the scrolling I added whitespace to the css (image d).

 

I checked the r/w rules per another post which is fine, checked document... removed quotes and extra spaces at the dita template level; added shift+enter again just for grins. I switched browsers... revised .css  and none of these steps help resolve the issue. Any idea? Image attached. Thank you!

codeblockPrettyPrint.png

 Note: Posted in RH and FrameMaker forum. 

TOPICS
Formatting and numbering, Publishing, Responsive HTML5, Structured

Views

97

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CodeBlock Breaks in FM HTML5 Output...

New Here ,
Nov 05, 2019

Copy link to clipboard

Copied

In FM 11 shift + enter at each line generated pretty codeblock in my html web page. Using HTML5 via FrameMaker 2017 (structured) > Publish +1k Topics > HTML 5 -  the pretty print on my codeblock element breaks, shows as one continuous line (image a). When I compile only one topic, the same topic, or a handful of topics (6 topics) that contain the codeblock element in a separate ditamap, the codeblock is well formed (image e). FrameMaker topics and user guide retains and shows the codeblock in pretty print (image f). I have one topic that contains several distinct chunks of code, oddly, one of the chunks is well formed (image c) but the other two break in the same topic. To quick fix the scrolling I added whitespace to the css (image d).

 

I checked the r/w rules per another post which is fine, checked document... removed quotes and extra spaces at the dita template level; added shift+enter again just for grins. I switched browsers... revised .css  and none of these steps help resolve the issue. Any idea? Image attached. Thank you!

codeblockPrettyPrint.png

 Note: Posted in RH and FrameMaker forum. 

TOPICS
Formatting and numbering, Publishing, Responsive HTML5, Structured

Views

98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 05, 2019 0

Have something to add?

Join the conversation