Highlighted

Generate DITA-OT output doesn't produce anything (wrong version of Java?)

New Here ,
Aug 18, 2016

Copy link to clipboard

Copied

FrameMaker 2015: I am unable to generate anything from the "DITA > Generate DITA-OT output" menu command.

First problem was that trying any of the three output options in the Generate DITA-Output menu produced a command window with this error:

Unable to locate tools.jar. Expected to find it in c:\ProgramData\Adobe\CS5\lib\tools.jar.

Buildfile: c:\Program Files (x85)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\build.xml

I had no c:\ProgramData\Adobe\CS5\lib folder, but found a "\lib\tools.jar" file in my Java directory, and copied the "lib" folder to the location that FM was looking for.

That at least made that error message go away, but produced a log file with this error:

BUILD FAILED

C:\Program Files (x86)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\build.xml:113: The following error occurred while executing this line:

C:\Program Files (x86)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\plugins\org.dita.base\build_init.xml:99: java.lang.UnsupportedClassVersionError: org/dita/dost/invoker/ExtensibleAntInvoker : Unsupported major.minor version 51.0

Does this mean that I have the wrong version of Java -- if so, which version should I have? Or does it mean something else?

TOPICS
Structured

Views

335

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Generate DITA-OT output doesn't produce anything (wrong version of Java?)

New Here ,
Aug 18, 2016

Copy link to clipboard

Copied

FrameMaker 2015: I am unable to generate anything from the "DITA > Generate DITA-OT output" menu command.

First problem was that trying any of the three output options in the Generate DITA-Output menu produced a command window with this error:

Unable to locate tools.jar. Expected to find it in c:\ProgramData\Adobe\CS5\lib\tools.jar.

Buildfile: c:\Program Files (x85)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\build.xml

I had no c:\ProgramData\Adobe\CS5\lib folder, but found a "\lib\tools.jar" file in my Java directory, and copied the "lib" folder to the location that FM was looking for.

That at least made that error message go away, but produced a log file with this error:

BUILD FAILED

C:\Program Files (x86)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\build.xml:113: The following error occurred while executing this line:

C:\Program Files (x86)\Adobe\AdobeFrameMaker2015\fminit\ditafm\DITA-OT\plugins\org.dita.base\build_init.xml:99: java.lang.UnsupportedClassVersionError: org/dita/dost/invoker/ExtensibleAntInvoker : Unsupported major.minor version 51.0

Does this mean that I have the wrong version of Java -- if so, which version should I have? Or does it mean something else?

TOPICS
Structured

Views

336

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 18, 2016 0

Have something to add?

Join the conversation