Highlighted

Scaling an image in table cell

Explorer ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi

I'm trying to create a table having the used symbols in one column and explanations in another column. When I add an image to a cell it is added in original size and the table is updated according to the size.

 

I found info telling that there should be an option how to make the image to scale automatically to the size of cell. You should add "AutoScaleImageInTableCell=On" to maker.ini file. Well, I did this but it didn't work. I updated my Framemaker 2019 earlier today so the update related to this should be available.

 

Any idea, what is wrong?

I received a reply from support. After investigation this was identified as a bug.

TOPICS
Structured

Views

446

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Scaling an image in table cell

Explorer ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi

I'm trying to create a table having the used symbols in one column and explanations in another column. When I add an image to a cell it is added in original size and the table is updated according to the size.

 

I found info telling that there should be an option how to make the image to scale automatically to the size of cell. You should add "AutoScaleImageInTableCell=On" to maker.ini file. Well, I did this but it didn't work. I updated my Framemaker 2019 earlier today so the update related to this should be available.

 

Any idea, what is wrong?

I received a reply from support. After investigation this was identified as a bug.

TOPICS
Structured

Views

447

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 21, 2020 0
Adobe Community Professional ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi,

 

Did you follow Stefan's explanation here?

https://blogs.adobe.com/techcomm/2019/08/framemaker-2019-update-4.html 

This option must be added to the Preferences section.

Was FrameMaker closed, when you edited maker.ini?

Do you really have update 4? Please check in the Help menu.

Which file format did you use?

I just tested this, and this works.

 

Here are also explanations:

https://www.daube.ch/docu/fmaker65.html 

https://helpx.adobe.com/framemaker/kb/fixed-issues.html 

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
Explorer ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi

Thank you for your reply. Your links (first and third) were the same where I originally learned about this option.

Help-Updates tells me that it is up to date, so it should be the latests one.

I added the option to the preferences section. At first it was in a wrong section as I didn't notice that the section was changed. After that I deleted the line added and added it to the preferences section. Could this cause some problem? Is there some kind of reset I must do for it?

Br,

Pekka

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
Explorer ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi

Forgot to mention, I have tried .jpg and .png files.

I made a new maker.ini file this morning. I copied the text from maker.ini  to Notepad and save it as .ini. I left the option out and then later added it again (Framemaker closed), still not working.

I have tried adding the image

- File-Import-File

- Insert-Image

- Added element "fig" and then element "image"

Br,

Pekka

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
Adobe Community Professional ,
Jan 21, 2020

Copy link to clipboard

Copied

Hi,

 

I do not believe that it matters, if you had entered this option in the wrong section and then moved it to the correct section.

However, you have to close FrameMaker before you edit maker.ini.

And it's always recommended to make a backup before you change anything.

 

Is the maker.ini the correct one? Do you see e.g. the last search strings or the last open files?

 

And although FrameMaker says that your version is up-to-date, I would check the version in Help | About.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
Explorer ,
Jan 22, 2020

Copy link to clipboard

Copied

That answer came quickly

Yes I can see the file I have used for testing this option

---------------------------------------

[RecentlyVisitedFiles]
0=C:\Documentation\TestingArea\20200121\TestConcept2.xml,0,0

----------------------------------------

Version is 15.0.4.751

Did you notice my previous message I was writing in the same time you answered?

I don't believe that Framemaker has been open while editing maker.ini. But if it has, what you have to do to make Framemaker to notice the new option? I'm getting out of ideas so every possibility must be tested.

Br,

Pekka

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Adobe Community Professional ,
Jan 22, 2020

Copy link to clipboard

Copied

Re how to make Frame notice the update to the maker.ini file if it was open while you edited the maker.ini file: close and restart FrameMaker.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Adobe Community Professional ,
Jan 22, 2020

Copy link to clipboard

Copied

Hi Pekka,

 

What I would test:

Change one of the other options and see, if this takes effect. Then you can see whether everything works generally.

Obviously you use structured FrameMaker (DITA or something else). Possibly this interferes here. Maybe someone with more experience here has any idea.

I would send an e-mail to the FrameMaker support: tcssup@adobe.com 

Ask there, if they could help. Add also a link to this discussion.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Explorer ,
Jan 22, 2020

Copy link to clipboard

Copied

Hi

At least information is updated in the file. Recently visited files list is updated as should and same with the LastActiveView.

I'll contact the support and ask about this. If I get any more information I'll update it here.

Thank you for your time!

Br,

Pekka

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Advocate ,
Jan 25, 2020

Copy link to clipboard

Copied

Well, PMYM,

Close FM, before you  update maker.ini

That's the required sequence.

You can update maker.ini while FM is open, but this update is useless. At close of  FM writes maker.ini which is a modified version (recent files opened, recent directories) of what it found at start.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2020 0
Explorer ,
Jan 28, 2020

Copy link to clipboard

Copied

I received a reply from support. After investigation this was identified as a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2020 0