Highlighted

table not breaking across columns

Explorer ,
Nov 30, 2016

Copy link to clipboard

Copied

I am working on a medical device user manual, 3-columns per page, and there are many warnings and precautions that are set up as tables so that a caution icon can appear to the left of the Warning/Caution text in the first row. Subsequent rows are a different para format.

I need these tables to extend to the bottom of a column before breaking, which is not the behavior I'm seeing. Can anyone help? I'm having the same problem with some of my other paragraph styles.

So they look like this:

Row1 Col1 <cool caution icon> Row1 Col2 WARNING -> para format for these both set to orphans=1, no keep with next/prev set

Row2 - columns are straddled and the specific warning content may go on for 10-15 lines since it is a 3-column format. -> this para format set to orphans =2, no keep with next/prev set.

The table itself has orphan rows = 2, but this is clearly not what is happening. table break issue.JPG

Can anyone think of any other reason these are not breaking properly? Thanks in advance!!

Views

279

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

table not breaking across columns

Explorer ,
Nov 30, 2016

Copy link to clipboard

Copied

I am working on a medical device user manual, 3-columns per page, and there are many warnings and precautions that are set up as tables so that a caution icon can appear to the left of the Warning/Caution text in the first row. Subsequent rows are a different para format.

I need these tables to extend to the bottom of a column before breaking, which is not the behavior I'm seeing. Can anyone help? I'm having the same problem with some of my other paragraph styles.

So they look like this:

Row1 Col1 <cool caution icon> Row1 Col2 WARNING -> para format for these both set to orphans=1, no keep with next/prev set

Row2 - columns are straddled and the specific warning content may go on for 10-15 lines since it is a 3-column format. -> this para format set to orphans =2, no keep with next/prev set.

The table itself has orphan rows = 2, but this is clearly not what is happening. table break issue.JPG

Can anyone think of any other reason these are not breaking properly? Thanks in advance!!

Views

280

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 30, 2016 0
Engaged ,
Nov 30, 2016

Copy link to clipboard

Copied

Couple of points (I'm sure Barb will tell me when I'm wrong :-))...

  • Table rows do not break across pages/columns. That is, if the content in a cell is too long to fit on the current page, the row will appear on the next page (or column, in your case).
  • Now, in your second page column (the middle column), I would have expected the PRECAUTION row to appear at the end of the first column, and the 'CHECK your infusion' to appear at the top of the second column because it is too long to fit in the space at the end of the first column.
    That's obviously not happening, and that is probably because the *row format* for the PRECAUTION row is set to Keep with Next Row, or the *row format* for the "Check your infusion" row is set to Keep with Previous Row.

    You can kludge these to fit by removing the keep with next/prev row setting(s) on those two rows (which moves the PRECAUTION to the end of the first column), and then adding an extra row below the 'Check your infusion' and move some of the trailing text from the original row into the new row (that will make it 'look' like it's breaking).
  • The numbered steps in the middle column (step #4) doesn't appear to be in a table -- Your '?' as to why the second line has moved to the top of the third column would be (I'm guessing) because the table marker is at the end of the paragraph, so it moves to the top of the third column where the table can begin (enough space there). To 'fix' this, at the end of the sentence ".. and remove the...", put a carriage return so the table marker sits on its own line and the table will sit by itself in the third column. Note that the table will be one line down from the top of the column... you could adjust the height of the line that the table marker is on to 2pt (the minimum) so that the table moves up as far as possible.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 1
Explorer ,
Nov 30, 2016

Copy link to clipboard

Copied

I can't believe I've never run into this before! I suppose because I haven't worked much with multi-column formats. Kludging is complete...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 0
Adobe Community Professional ,
Nov 30, 2016

Copy link to clipboard

Copied

I'm sure Barb will tell me when I'm wrong 🙂

LOL! The only thing I have to add is that you can set the blue note table to Float and that way it will move to the top of the 3rd column, and allow the text that is currently at the top of the column to head back to the bottom of column 2 without having to add the extra return.

VMware Fusionss_010.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 1
Engaged ,
Nov 30, 2016

Copy link to clipboard

Copied

🙂

wonderful! (as mentioned in another thread, I dropped directly into working full-tilt with FrameMaker, and back-filled my knowledge over time, with the result that some of these little bits that I never encountered were not obvious to me)

THANKS! (I'll be floating some tables myself tonight 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2016 1