Highlighted

xref does not show correct chapter number in DITA xml

Contributor ,
Jul 01, 2020

Copy link to clipboard

Copied

I use FM 2020 to set up my DITA books in which I use bookmaps to organize individual chapters and ditamaps to create the map for each chapter and xml file format in order to store content.

Now, if I set the style of the figure.title to f:Figure <$chapnum>.<n+>: \sn via the paragraph designer, the numbering of figure captions correctly reflects the corresponding combination: chapter number.figure number, such as Figure x.y which means figure number y in chapter x. However, cross-referencing to these figures is not correcly done: that is the value for chapter number (x) is always 1 in every chapter.

Is that something I can fix or it is rather a bug?

TOPICS
Formatting and numbering, Structured

Views

67

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

xref does not show correct chapter number in DITA xml

Contributor ,
Jul 01, 2020

Copy link to clipboard

Copied

I use FM 2020 to set up my DITA books in which I use bookmaps to organize individual chapters and ditamaps to create the map for each chapter and xml file format in order to store content.

Now, if I set the style of the figure.title to f:Figure <$chapnum>.<n+>: \sn via the paragraph designer, the numbering of figure captions correctly reflects the corresponding combination: chapter number.figure number, such as Figure x.y which means figure number y in chapter x. However, cross-referencing to these figures is not correcly done: that is the value for chapter number (x) is always 1 in every chapter.

Is that something I can fix or it is rather a bug?

TOPICS
Formatting and numbering, Structured

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 01, 2020 1
New Here ,
Oct 05, 2020

Copy link to clipboard

Copied

I am having a very similar problem in that my chapter and figure numbers do not process correctly. I am not using as complex a system, I simply have ditamaps with topics in a hierarchy. I hope someone posts an answer soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Contributor ,
Oct 05, 2020

Copy link to clipboard

Copied

Hi check here for an answer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
New Here ,
Oct 22, 2020

Copy link to clipboard

Copied

Hi I checked the other reply and didn't see how it applied to my situation. I believe what's happening is that the xrefs are resolved before the chapter numbering is completed. Does anyone else have misnumbered figure and topic references?

My figure references are defined using the cross-reference format Figure with Number (i.e. Figure 1) which is defined as: <link.xref>Figure <$elemparanumonly>

The figures are auto-numbered using the following definition: f:Figure <$chapnum>-<n+>:\t

 

Wanda

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0
Contributor ,
Oct 22, 2020

Copy link to clipboard

Copied

Please also have a look at this thread 

It is possible that you are facing the same issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0
Community Beginner ,
Oct 22, 2020

Copy link to clipboard

Copied

Just in case, open DITA options (Esc D O) and make sure that "Autoload Xrefs On File Open" is ticked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0
Wodge LATEST
New Here ,
Oct 22, 2020

Copy link to clipboard

Copied

Done that, thanks. Still have the same problem. I think it's an FM 2020 issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0