Highlighted

xref within a conref breaking

Participant ,
Oct 22, 2018

Copy link to clipboard

Copied

I have a conref to content that includes a xref. This looks like it works ok until I save my ditamap as a book and look at the resulting fm file. At which point the nested xref has disappeared (the fm-xref element exists but only contains WHITESPACE as the visible text, the href property is still present but the link is broken).

Is there a way to make this work?

Thanks!

TOPICS
Structured

Views

296

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

xref within a conref breaking

Participant ,
Oct 22, 2018

Copy link to clipboard

Copied

I have a conref to content that includes a xref. This looks like it works ok until I save my ditamap as a book and look at the resulting fm file. At which point the nested xref has disappeared (the fm-xref element exists but only contains WHITESPACE as the visible text, the href property is still present but the link is broken).

Is there a way to make this work?

Thanks!

TOPICS
Structured

Views

297

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 22, 2018 0
Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

I would really appreciate a solution to this if one exists - does anyone know? I'm just having to reorganise my content to move the links out of the reused sections at the moment.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
Adobe Employee ,
Dec 06, 2018

Copy link to clipboard

Copied

Can you share the build number from About FrameMaker which you are using. I tried this with FM2019 Update 2(internal build) and when saved the ditamap as Book with components and in the final fm document the xref which was part of a conref came in correctly and link is not broken. If you could share a small sample file where this issue is coming and i could send you the updated book file with internal Update 2 build. Update 2 is planned for release next week.

Thanks

Amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2018 1
Participant ,
Dec 06, 2018

Copy link to clipboard

Copied

Thanks Amitoj. I first saw the problem in FM 2017, but am now using FM 2019, version 15.0.1.430.

What's the best way to share files with you?

Kat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2018 0
Adobe Employee ,
Dec 06, 2018

Copy link to clipboard

Copied

please mail them to me amisingh@adobe.com

thanks

Amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2018 0
Contributor ,
Oct 01, 2019

Copy link to clipboard

Copied

Hi, were you able to solve the problem? I have a similar issue with xref which is inside a conref and all into a book. Very frustrating...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2019 0