illustrator running painfully slow.

New Here ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Illustrator is runing very slowly full stop (Moving objects around on screen is very sluggish etc) but the most frustrating aspect which is making it almost unusable is when i try to use text. i create a text box and start typing and its fine but then it just stops and shows the spinning beach ball. whenever i try to select parts of the text it shows the beach ball for a few seconds making the experience very frustrating. I tried disabling all my fonts to see if there was a problem there to no avail. running mohave on iMac (Retina 5K, 27-inch, Late 2015) with new SSD. illustator 24 freshly updated.

Any help to solve this would be much appreciated.

TOPICS
Performance , Type

Views

390

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jun 26, 2020 Jun 26, 2020

For anyone interested the issue was resolved by resetting my preferences. - such a simple change and such a dramatic effect!

Likes

Translate

Translate
New Here ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

For anyone interested the issue was resolved by resetting my preferences. - such a simple change and such a dramatic effect!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 13, 2020 Jul 13, 2020

Copy link to clipboard

Copied

Thank you very much I was going crazy!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2020 Jun 29, 2020

Copy link to clipboard

Copied

After InDesign driving me so crazy with spinning beach ball hang ups for the past 2 years that I've actually rebuilt files in Illustrator and even in MS Word to avoid having to use it, I've FINALLY found a fix... well... sort of.  I had tried ALL of the recommendations like trashing prefs, etc... none of which worked for more than a few moves before the friggin' beach ball started spinning again. What FINALLY works is turning off WIFI, which unfortunately disconnects me from the Web, making multi-tasking impossible, of course — no email, etc. — but it DOES let InDesign actually opertae as it is supposed to — and used to — before CC 2019, so I can actually get something done.  Not ideal, but definitely helpful.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2022 Sep 11, 2022

Copy link to clipboard

Copied

LATEST

Same here. Too bad I'm working remotely ... 😄

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines