IllustratorGc.jsx script error while launching Illustrator 25.3

Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Updated this morning to Illustrator 25.3 - as soon as the update was done this scripting error began appearing (every 30 seconds). .. Personally went back to 25.2.3 which has solved this issue. 

 

Screen Shot 2021-06-08 at 10.01.26 AM.png

 

 

{Renamed by MOD}

TOPICS
Bug, Performance

Views

45.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Aug 25, 2021 Aug 25, 2021
We are investigating this issue and reached out to Logitech for permanent solution. Meanwhile users can try the below workaround. Create a JSX file with the following content: app.preferences.setBooleanPreference("ShowExternalJSXWarning", false); Save the above JSX file. Now, go to File > Scripts > Other Script, and choose the newly saved jsx file. This will suppress the warning dialog and run the script.

Likes

Translate

Translate
Adobe Employee , Oct 11, 2021 Oct 11, 2021
Hi all, We hope the issue is resolved by now. If not, please update the logitech driver to latest version (9.40.75) and share your observations with us. Regards, Srishti

Likes

Translate

Translate
replies 185 Replies 185
Adobe Community Professional ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

There is no need for a code editor. Just any software that can save plain text files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 11, 2021 Oct 11, 2021

Copy link to clipboard

Copied

Hi all,

 

We hope the issue is resolved by now. If not, please update the logitech driver to latest version (9.40.75) and share your observations with us.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2021 Oct 11, 2021

Copy link to clipboard

Copied

Not really for me.

I have a Mac mini M1 and now after updating Illustrator and Logitecth Option I have this error. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

I have updated it twice and reinstalled Illustrator, and nothing has changed.

 

I tried writing the jsx-file, but I get an 'Error 8: Syntax error'. I didn't really expect that I would be able to write a workaround like this, and that suspicion was confirmed.

 

The situation seems hopeless. Is my only option to just uninstall the Logitech software and accept that I cannot use it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

I am also having this issue.  In regards to the two suggested solutions:

 

1. They say to install Logitech v. 9.40.86, but the link above goes to v. 9.40.75 (and is also the latest version when doing a "check for updates" inside the app).  So that's a dead end.

 

2.  I want to try the JSX file solution, but the instructions don't say how to create one.  I used TextEdit and copied the above script, saved the file as .rtf and then changed the file extension to .jsx, but got the "Error 8: Syntax error" described above.  What program do you use to create a JSX file?  Alternatively, can someone at Adobe just post the file for us all rather than making each user create their own?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

Instead of letting TextEdit save the file as an .rtf, force it to save the file as a plain text file (.txt) and then change the extension to .jsx. It should be able to run then.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

Thanks Larry!   That worked.  Though, for anyone else trying this, it isn't as intuitive as just "save as .txt" from TextEdit.  In TextEdit, you click on the menu that says "Format" and then select "Make plain text" and then you can save it as a .txt file and rename it to .jsx.  And the fix does seem to work.  Been running Illustrator a few minutes without the error message.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Hi I.M.Tired, does it matter how the file is named?

Somehow none of the explantions is really intuitive. Can you post a screenshot with visible filename and textfield? Would be much appreciated. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

It doesn't matter how the file is named, as you select and run it. As long as it is a plain text file with the extension .jsx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Thanks for the reply. I tried something different while waiting and had no error message since.

 

1. name the rtf file IllustratorGc.rtf 

2. copy & paste the text: app.preferences.setBooleanPreference("ShowExternalJSXWarning", false);

3. save & rename the file as IllustratorGc.jsx

4. search for all files IllustratorGc.jsx on your Mac  > found in two different Logitec folders

5. overwrite with new IllustratorGc.jsx

6. enjoy no error messag

 

Works fine for me & I hope it hepls others.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I'm pretty sure IllustratorGc.jsx is something included in Logitech Options that it needs to run.

The script in this topic is just to supress the warning dialog, not to replace the Logitech script itself -- though perhaps by deleting the script, you have solved the problem in a manner of speaking.

Don't save an RTF file. Save as plain text. There are many posts above emphasising this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines